Doctypes, CSS, HTML and a pinch of ARGHHH

  • Blackfire
  • Newbie
  • Newbie
  • Blackfire
  • Posts: 6

Post 3+ Months Ago

Hello There.
I used to be a member on here along time ago. I think my account got deleted since then for been inactive for years.

Anyway, to the point. PLEASE HELP!!!

This is going to be ironic, I design websites as a hobbie for people, im not a newbie, but im not fantastic either. Most of my work is done in photoshop and I modify free templates normally.
just updating my own website (using latest version of wordpress)

This is my doctype
Code: [ Select ]
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">


If you look at this page
http://home.blackfiredesigns.com/asatru

in Internet explorer, it looks fine, take another look in firefox, and you will see that the header menu drops down by 4 pixels at the bottom of each image.

Ive ran through my CSS file scratching my head like mad and cant seem to find where the problem is.

CSS file is located here
http://home.blackfiredesigns.com/wp-con ... /style.css



I know you may need more information from me to help me, but my head is buzzing right now and i cant really think of what else I can write.

Thanks in advance
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • natas
  • PHP Ninja
  • Proficient
  • natas
  • Posts: 308
  • Loc: AFK

Post 3+ Months Ago

Try adding this to your CSS. I'm not positive it will fix, but it's worth a shot.

Code: [ Select ]
img {
  display: block;
}
  1. img {
  2.   display: block;
  3. }
Moderator Remark: code tags
  • Blackfire
  • Newbie
  • Newbie
  • Blackfire
  • Posts: 6

Post 3+ Months Ago

HA, it does work, but it did something else to some of my pictures as well. So i added a little extra to the code you gave me,

.imghead { display: block; }

Then created a class in my images in my header to imghead and presto
Everything is perfect.

I could kiss ya, lol *metaphorically speaking of course, lol*

I can't belive it was somthing so simple. I bet w3c validator has a field day with my site tho. lol


THANK YOU VERY MUCH
  • natas
  • PHP Ninja
  • Proficient
  • natas
  • Posts: 308
  • Loc: AFK

Post 3+ Months Ago

This will explain what happened better than I can.

http://www.schoonzie.com/rogue-padding-below-images

Just in case you were wondering.
  • Blackfire
  • Newbie
  • Newbie
  • Blackfire
  • Posts: 6

Post 3+ Months Ago

thank again for the link, but after we sorted it, i did a little look into the background of img display block and i found this

http://www.quirksmode.org/css/quirksmode.html

under the heading
Complication: almost strict mode
at the bottom.

after looking through my css and html, i realised it was the doctype that was cuasing the problem, i just didnt know why, but i do now

again, thank you very much.

Post Information

  • Total Posts in this topic: 5 posts
  • Users browsing this forum: No registered users and 47 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.