drop down menu only works on index and nothing else

  • Zealous
  • Guru
  • Guru
  • User avatar
  • Posts: 1244
  • Loc: Sydney

Post 3+ Months Ago

I am on the clock with this but working with this template and the drop down list is not working with anything apart from the index. I am trying to debug the situation but can't seam to track down the issue.


www.zday.com.au

on the index the 2nd menu item drops and then after going through the link there is no drop down active anymore.

really need some help on this one.
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9090
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

Looks like you have a few problems. First you are getting the TypeError that $.browser is undefined. This is most likely because you are using a newer version of jQuery that no longer has that function. It was deprecated awhile back and you need to update any scripts that use that, as that is no longer supported.

Second it looks like you are depending on fancybox, but you are getting a TypeError that fancybox is not a function. Could be related to the above, but most likely you are not loading the fancybox plugin before calling that function.

Looking at your source code, it looks like you are loading the same set of JavaScript twice in the footer. You are loading jquery twice, carouFredSel twice, cslider twice, getTweet twice, etc. All of this could cause issues, so I would clean that up.

The actual problem I think is that on the pages your menu is not working, you are loading way way less JavaScript. On the homepage you are often loading things twice, but on your other pages you are not, but many of things that may be required you are not loading at all.

Sometimes having all of these JavaScript errors can prevent anything else from firing, so I kind of have a feeling that could be your problem. It would be nice if you fix those problems to make sure we can rule that out before looking into it further.
  • Zealous
  • Guru
  • Guru
  • User avatar
  • Posts: 1244
  • Loc: Sydney

Post 3+ Months Ago

i was reading over the pages last night and i kinda had the same feeling but had to get to bed get my 4 hours sleep and back to work again. But that seams like the case as the CSS and HTML seam fine.

shouldn't take that long to figure out what is missing but shall post up if i find more errors.

Thanks BWM, much appreciate the diagnosis.
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9090
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

No problem, if it still persists after resolving those issues, I would be happy to look again.
  • Zealous
  • Guru
  • Guru
  • User avatar
  • Posts: 1244
  • Loc: Sydney

Post 3+ Months Ago

Once again the master was right, i have not completely determined exactly how much was required but got it working with some changing around.

now i got less then 1 day to finish this off lol oh joy. All most there tho bugger all to do now. Just clean things up.

Thanks BMW your help is much appreciated.
  • Zealous
  • Guru
  • Guru
  • User avatar
  • Posts: 1244
  • Loc: Sydney

Post 3+ Months Ago

there is 1 thing that i have also found a small issue that i went to test the mobile on my iphone 3GS and the logo is loading the full size computer size. Just wondering if there is a switch i could get to resize on mobile detect. i am sure if i googled and researched i would find it but just wondering if someone had a snippet on hand.

Cheers
  • Bigwebmaster
  • Site Admin
  • Site Admin
  • User avatar
  • Posts: 9090
  • Loc: Seattle, WA & Phoenix, AZ

Post 3+ Months Ago

I would just go to your devices.css file and find the mobile version spot, or whatever spot you want to modify, and then add:

CSS Code: [ Select ]
#logo img { width:300px; }


Or whatever width you want it.
  • Kurthead+1
  • Graduate
  • Graduate
  • Kurthead+1
  • Posts: 131

Post 3+ Months Ago

It may not be really helpful, but the site looks really cool.
  • Zealous
  • Guru
  • Guru
  • User avatar
  • Posts: 1244
  • Loc: Sydney

Post 3+ Months Ago

Bigwebmaster wrote:
I would just go to your devices.css file and find the mobile version spot, or whatever spot you want to modify, and then add:

CSS Code: [ Select ]
#logo img { width:300px; }


Or whatever width you want it.


makes me think how wonderful CSS can be.

love your work BMW
  • Zealous
  • Guru
  • Guru
  • User avatar
  • Posts: 1244
  • Loc: Sydney

Post 3+ Months Ago

Kurthead+1 wrote:
It may not be really helpful, but the site looks really cool.


what do you mean it may but be really helpful?

the site is for a client of mine which is for a RPG zombie survivor laser skirmish experience and not sure if you noticed yet that it is not finished. this is only the beta site, i plan to make further upgrades to it but just needed to get something working before super nova expo next weekend.

What helpful web sites have you got? :)
  • Kurthead+1
  • Graduate
  • Graduate
  • Kurthead+1
  • Posts: 131

Post 3+ Months Ago

Ha. By "not helpful", I meant that what I was saying had nothing to do with your question (sorry about the confusion; it had nothing to do with the site's functionality or informational merit). It was just a compliment on the template. I could tell that it wasn't finished but I liked the template, and as of now it looks cool. That was all of the message I was attempting to convey.

That's so funny that I didn't consider how my post could've been interpreted.

Edit: And I did build a smoking health-factors/calculator for an anti-smoking website; it may be a little helpful, but I can't be sure. I'm sure you have built many many many more than I have though.

(I would've been annoyed/pissed too if some 4 month experienced coder casually insulted my site, in your position. I wouldn't even have clients now without your guys' help.)

Post Information

  • Total Posts in this topic: 11 posts
  • Users browsing this forum: No registered users and 70 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.