Homepage loading slowly or not at all - help

  • UVBoy
  • Beginner
  • Beginner
  • User avatar
  • Posts: 50
  • Loc: London, Ontario, Canada

Post 3+ Months Ago

Hello,

I recently submitted my website http://www.aquatell.com to the website review forum. I got lots of excellent feedback and had one of my suspicions validated - my homepage will often not load or takes a very long time (20+ seconds) for some users - even those with high speed connections.

More details: First try is extremely slow or unsuccesful. Attempt 2, 3, 4, etc. will work every time. Not everybody experiences this slow or non-loading. It only seems to affect some people some of the time. You can understand my concern with this situation. I am having great success with SEO but if I don't get this sorted out it's all a big waste of time.

I am not a programmer (although the more I learn the more I'm wishing I was). I rely upon a company to do the programming for my website. I normally like to figure these sorts of fundamental issues out on my own but I really need some help on this one. I've gone back to my programmer and he doesn't know what's happening.

Please help! I don't need anybody to dive too deep into this - I'm mostly looking for some leads that I can follow up on at this point. Or, ideally, someone else had the same problem and knows a quick fix.

THANK YOU!
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • Don2007
  • Web Master
  • Web Master
  • Don2007
  • Posts: 4924
  • Loc: NY

Post 3+ Months Ago

It loaded in Internet Explorer with no problem but took forever in Firefox. Trying to make a web site compatible with both browsers can be a problem.

The page source shows that you leaned towards IE with mostly MS compatible scripting. That could be your problem.

<meta name="GENERATOR" content="Microsoft Visual Studio .NET 7.1">
<meta name="CODE_LANGUAGE" content="Visual Basic .NET 7.1">
<meta name="vs_defaultClientScript" content="JavaScript">
<meta name="vs_targetSchema" content="http://schemas.microsoft.com/intellisense/ie5">

Post Information

  • Total Posts in this topic: 2 posts
  • Users browsing this forum: No registered users and 67 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.