IE6 layout bug - any suggestions?

  • caravan5
  • Novice
  • Novice
  • caravan5
  • Posts: 20

Post 3+ Months Ago

Hi there

I've been building a new page on our site that has bascially the same layout as all the others. It works fine in IE7 and FF, but in IE6 the layout goes a bit wrong.

There should be a green box that lines up with the top of the content and sits to the righthand side, however, in IE6 the green box moves to the bottom of the page and sits on the left hand side.

I thought it may be something to do with the table, as this is not on any other page, so I tried removing it, but it made no difference.

Anyone know if there's a quick fix without affecting all the other pages with the same layout?

problem page: caravanguard.co.uk/test/tracking.php

Thank you in advance
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • graphixboy
  • Control + Z
  • Mastermind
  • User avatar
  • Posts: 1828
  • Loc: In the Great White North

Post 3+ Months Ago

well I can't get to your server, but typically that problem stems from IE6's incorrect understanding of the box model. Typically IE6 attempts to ADD width and padding instead of subtracting the padding from the width like most other browsers. As a general rule of thumb its a bad idea to use both and it will force things to wrap to another line. Again this is just a guess since I can't see your page.

Post Information

  • Total Posts in this topic: 2 posts
  • Users browsing this forum: No registered users and 21 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.