Iframe Problerm

  • johny30238
  • Born
  • Born
  • johny30238
  • Posts: 3

Post 3+ Months Ago

Hey,
I have been working on this for a couple of hours now and cant figure it out. I trying to set my page where it opens all links in a Iframe, but so far it has failed. Heres my source:

Code: [ Select ]
<map name="id1_A_Map">
<area shape="rect" alt="Home" coords="20,19,180,122" href="../index.html" target="conframe">
</map>
<map name="id4_D_Map">
<area shape="rect" alt="Links" coords="20,67,152,138" href="../links.html" target="_conframe">
<area shape="rect" alt="Home" coords="20,7,152,67" href="../index.html" target="_conframe">
</map>
<map name="id6_F_Map">

<area shape="rect" alt="Forum" coords="20,65,152,132" href="../forum/" target="_parent">
<area shape="rect" alt="Free Web Proxy" coords="20,0,152,65" href="../proxy/index.php" target="conframe">
</map>
<map name="id8_H_Map">
<area shape="rect" alt="About Me" coords="20,0,152,65" href="../about.html" target="_conframe">
</map>
<map name="id11_K_Map">
<area shape="rect" alt="Myspace Profile" coords="180,36,351,65" href="http://www.myspace.com/mmhs_hacker" target="_blank">
</map>
</div>
<div style="position:absolute; left:480px; top:68px; width:491px; height:460px; background-color:transparent; overflow:auto; z-index:2;">
<iframe id="conframe" allowtransparency="true" height="460" width="491" frameborder="0" style="position: absolute; top: 68px; left: 480px;" src="http://www.google.com" ></iframe>
</div>
  1. <map name="id1_A_Map">
  2. <area shape="rect" alt="Home" coords="20,19,180,122" href="../index.html" target="conframe">
  3. </map>
  4. <map name="id4_D_Map">
  5. <area shape="rect" alt="Links" coords="20,67,152,138" href="../links.html" target="_conframe">
  6. <area shape="rect" alt="Home" coords="20,7,152,67" href="../index.html" target="_conframe">
  7. </map>
  8. <map name="id6_F_Map">
  9. <area shape="rect" alt="Forum" coords="20,65,152,132" href="../forum/" target="_parent">
  10. <area shape="rect" alt="Free Web Proxy" coords="20,0,152,65" href="../proxy/index.php" target="conframe">
  11. </map>
  12. <map name="id8_H_Map">
  13. <area shape="rect" alt="About Me" coords="20,0,152,65" href="../about.html" target="_conframe">
  14. </map>
  15. <map name="id11_K_Map">
  16. <area shape="rect" alt="Myspace Profile" coords="180,36,351,65" href="http://www.myspace.com/mmhs_hacker" target="_blank">
  17. </map>
  18. </div>
  19. <div style="position:absolute; left:480px; top:68px; width:491px; height:460px; background-color:transparent; overflow:auto; z-index:2;">
  20. <iframe id="conframe" allowtransparency="true" height="460" width="491" frameborder="0" style="position: absolute; top: 68px; left: 480px;" src="http://www.google.com" ></iframe>
  21. </div>


The proxy link id the only Active link at the time Heres a link to the site

netvirus.no-ip.org

Can you please assist me with this problem. Thanks in advance
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • spork
  • Brewmaster
  • Silver Member
  • User avatar
  • Posts: 6252
  • Loc: Seattle, WA

Post 3+ Months Ago

You seem to be using two different ID's when specifying your target:

Code: [ Select ]
<area shape="rect" alt="Home" coords="20,19,180,122" href="../index.html" target="conframe">


Code: [ Select ]
<area shape="rect" alt="About Me" coords="20,0,152,65" href="../about.html" target="_conframe">
  • johny30238
  • Born
  • Born
  • johny30238
  • Posts: 3

Post 3+ Months Ago

spork wrote:
You seem to be using two different ID's when specifying your target:

Code: [ Select ]
<area shape="rect" alt="Home" coords="20,19,180,122" href="../index.html" target="conframe">


Code: [ Select ]
<area shape="rect" alt="About Me" coords="20,0,152,65" href="../about.html" target="_conframe">


Okay i fixed that, But its still not loading in the iframe.
  • spork
  • Brewmaster
  • Silver Member
  • User avatar
  • Posts: 6252
  • Loc: Seattle, WA

Post 3+ Months Ago

I haven't used iframes in a long time, but try setting the name attribute of the iframe to the same name as the ID.

Code: [ Select ]
<iframe id="conframe" name="conframe" allowtransparency="true" height="460" width="491" frameborder="0" style="position: absolute; top: 68px; left: 480px;" src="http://www.google.com" ></iframe>


I don't remember if the target in a link accesses the frame by id or by name, so it's worth a shot.
  • johny30238
  • Born
  • Born
  • johny30238
  • Posts: 3

Post 3+ Months Ago

spork wrote:
I haven't used iframes in a long time, but try setting the name attribute of the iframe to the same name as the ID.

Code: [ Select ]
<iframe id="conframe" name="conframe" allowtransparency="true" height="460" width="491" frameborder="0" style="position: absolute; top: 68px; left: 480px;" src="http://www.google.com" ></iframe>


I don't remember if the target in a link accesses the frame by id or by name, so it's worth a shot.


Problem FIXED! while look through the code i found a extra "

Code: [ Select ]
<area shape="rect" alt="Links" coords="20,67,152,138" href="../links.html" 'target="conframe">


like up top and bam it works thanks for the help, i guess its time for more coffee :)
  • spork
  • Brewmaster
  • Silver Member
  • User avatar
  • Posts: 6252
  • Loc: Seattle, WA

Post 3+ Months Ago

johny30238 wrote:
like up top and bam it works thanks for the help, i guess its time for more coffee :)

I hear that! :morning:

Post Information

  • Total Posts in this topic: 6 posts
  • Users browsing this forum: No registered users and 24 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.