iFrames and Safari problem - please help

  • roarmeow
  • Professor
  • Professor
  • User avatar
  • Posts: 861
  • Loc: BKNY

Post 3+ Months Ago

Hi,

First off, whoever writes me back on this is great.
Teaching myself has been a trial.

Anyways, my problem is this:
I've designed a site using iFrames for the content pages and, for some reason, it appears that the content space is showing up blank on Safari-users screens.

The site is : http://www.uu-uno.org

I'm not sure what's causing this and have looked into it in a number of places - also, I know a lot of people have a distaste for frames and iframes in particular, but I'd really prefer some advice on how to make what's already there work.

Thanks,

Puck
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • elektric
  • Graduate
  • Graduate
  • User avatar
  • Posts: 130
  • Loc: Mexico

Post 3+ Months Ago

I can see that the problem may be the value " allowtransparency="true" at the Iframe Tag, I builded 2 websites whith Iframes and I can see them well with Safari, but yours shows blank as you said, try removing this value. Try my work with iframes, you will notice they work on safari. http://www.juanangelcastillo.com http://www.nationalcar.com.mx

Good Luck.
  • roarmeow
  • Professor
  • Professor
  • User avatar
  • Posts: 861
  • Loc: BKNY

Post 3+ Months Ago

first off, thanks for looking into that. :)
at this point, your suggestion seems to be working...
however, i'd really like to actually have the iframes be transparent.
do you know of any alternative ways to make the blank spaces in an iframe be, well, transparent.

that said, thanks again and, dang... cross-browser compatibility is a punk... and why can't apple make some kinda safari emulator for PCs? actually, i think i know the answer to that one...

peace and blessings,
puck
  • elektric
  • Graduate
  • Graduate
  • User avatar
  • Posts: 130
  • Loc: Mexico

Post 3+ Months Ago

You can try setting up styles, to be honest I am not sure it is going to work under safari, but with some luck it may work.

Code: [ Select ]
<iframe src="somepage.html" width="600" height="400" style="filter:alpha(opacity=0)"></iframe>


Set the opacity depending your needs from 0 to 100.

I heard about some emulator for mac os X to run under PC, that's the only way I know to run safari on windows. So bad.

Good Luck.

Best Regards.
  • MikeLawrey32
  • Born
  • Born
  • MikeLawrey32
  • Posts: 1

Post 3+ Months Ago

Hello,

I was getting similar issues with my iframe, but only in Safari. All I did was change the width attribute to 100%, instead of the original pixel size and that worked.

Mike

Post Information

  • Total Posts in this topic: 5 posts
  • Users browsing this forum: No registered users and 91 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.