image won't show up in front page

  • rayrip
  • Newbie
  • Newbie
  • rayrip
  • Posts: 13

Post 3+ Months Ago

The other day I was working on Front page building some new pages and discovered I was working right on the net instead of my local machine... which is why it was so slow.

Anyway, the result is that the images won't resolve to the right path... even when I type in the image as vimages/touch1.jpg it changes to file:///I:/blueoneweb/vimages/touch1.jpg. Which I thought was normal, but when I publish the page it remains with the file:/// instead of resolving to the folder on the website.

Any idea's would sure be appreciated.

Thanks,

Ray
  • kbergmann
  • Expert
  • Expert
  • User avatar
  • Posts: 659
  • Loc: USA

Post 3+ Months Ago

First off the answer you seek is ... Here


Second:

you didn't save your page before you put on the image.

make the page on local machine.

SAVE.

add image ;)

Upload :)
  • rayrip
  • Newbie
  • Newbie
  • rayrip
  • Posts: 13

Post 3+ Months Ago

I deleted the image. Saved the page. Published it. No image was there. Inserted the image again. Published it. Same thing. When I look at my image properties on the website I get the file:///I:/blueoneweb/vimages/touch1.jpg instead of like most of my images vimages/whatever.jpg

Any other idea's?

Thanks,

Ray
  • kbergmann
  • Expert
  • Expert
  • User avatar
  • Posts: 659
  • Loc: USA

Post 3+ Months Ago

Ummm don't use front page :) but otherwise ...

Why don't you do it all on the local machine, save as you go, add images after saving, then publish when done.

That error I get when I forget to save before adding an image in DW. I never ever work on the live page on the site. One mistake can be a killer.

Also the file you are linking to might not be on the server but on your computer :)

Maybe a FP person might be able to help you better ...

And it might help to post a link to the page so I can see and test. And it might help to clear browser cache, temp internet files and do a hard refresh while the page is open. You might have fixed it ...
  • rayrip
  • Newbie
  • Newbie
  • rayrip
  • Posts: 13

Post 3+ Months Ago

Yeah, checked to make sure the image was on the server. I made one mistake and I'm doomed :-()

This is one of those things that I'll figure out and not forget it. It's a strange one. Going to get the upgrade to Front Page tomorrow to see if it works better. It's supposed to be better. I wish I would have started with DW but I've got so many sites in FP now I don't want to change.

Normally I don't have much of a problem.

Thanks anyway.

P.S.

I like the PEBKAC.

Ray
  • rayrip
  • Newbie
  • Newbie
  • rayrip
  • Posts: 13

Post 3+ Months Ago

I found out it's not the page, it's the picture. If I select a different image, it publishes fine. But these certain images keep changing the file name back to file:///I:/blueoneweb/vimages/touch1.jpg instead of vimages/touch1.jpg

Very strange. Guess I'll re copy the image back into the vimages folder... know not what else to do!

Ray
VMT
  • kbergmann
  • Expert
  • Expert
  • User avatar
  • Posts: 659
  • Loc: USA

Post 3+ Months Ago

I normally keep any page I make local then upload through ftp to the proper folder. That is a strange error but if you have the site locally, make the change then test, if it works upload.

have you tried re-uploading the image itself? Sometimes files just corrupt themselves and without a back up of them ... gotta remake, refind it, etc ... I have seen it happen with both pdf and images.

I have no clue how your server is set up ... but make sure the publichtml or what ever folder matches the www folder on the web. The change might not have taken place in both.
  • Bogey
  • Genius
  • Genius
  • Bogey
  • Posts: 8415
  • Loc: USA

Post 3+ Months Ago

kbergmann wrote:
Ummm don't use front page :)


I second that suggestion. Front Page is for the last resort only. By "last resort" is if you can't code. If you can code, Dreamweaver (for syntax highlighting) or Notepad as a first resort :lol:
  • Benat
  • Mastermind
  • Mastermind
  • User avatar
  • Posts: 2123

Post 3+ Months Ago

Simple solution if you have a little knowledge of coding, copy and paste the whole page code to notepad, find the image code with in it, and then change it to images/whatever.jpg (wherever your images is located on your server), then save as whatever.html. That way frontpage can not keep changing it back to the file name you mentioned.

Post Information

  • Total Posts in this topic: 9 posts
  • Users browsing this forum: No registered users and 46 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.