need HAAEEELP with two very annoying html/css glitches

  • celandine
  • Mastermind
  • Mastermind
  • User avatar
  • Posts: 2008
  • Loc: Belgrade, Serbia

Post 3+ Months Ago

Okayz this is a troubleshooting assignment, well, two of them - they're both driving me MENTAL, and I'm sure it's simply because I haven't done this web dev thing for ages and I've just forgotten to pay attention to the niggly little code details, but if anyone can solve these weird glitches for me I will be well and truly grateful!

Glitch no. 1 - I've got two pages running provisionally online - the index page and the image gallery page[Warning: NSFW art work]. Now most of the code for the two is virtually identical, which is why I can't understand why the horizontal navigation on the image gallery page just doesn't work. It's the same code as that on the index page, which works fine, so something else on the page must be messing it up.... and I just can't find it???

Glitch no. 2 - on the same site, and arguably even more annoying than the first - WHY IS THERE A BROWN GAP UP AT THE VERY TOP OF THE PAGE??? The orange header is meant to be all the way up, and any padding/ margin/ whatnot I could think of is set to 0, I think........ but it keeps giving me that gap. I must be failing to understand something very fundamental about positioning again (I do that a lot).

Really looking forward to any creative ideas! :D

EDIT: PS I know it doesn't validate but the validation problems are all improperly closed meta tags in the head, they shouldn't be causing the issues at hand and will be fixed soon.
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • UPSGuy
  • Lurker ಠ_ಠ
  • Web Master
  • User avatar
  • Posts: 2733
  • Loc: Nashville, TN

Post 3+ Months Ago

Solution to #1: The div #gallerynotes is covering the links. I edited the CSS to give it a height of 10px and I could use the links as well as keep content somewhat in place.

Solution to #2 (well, sort of): You've got a gap of 27px at the top caused by the relative positioning of #header. Consider what's 'positioned' prior to that in the code and maybe you can identify what's offsetting it. You could alternatively give it a top: of -27px to offset the positioning.
  • celandine
  • Mastermind
  • Mastermind
  • User avatar
  • Posts: 2008
  • Loc: Belgrade, Serbia

Post 3+ Months Ago

you are most wonderful!!! Thank you for the effort. My laptop just crashed kind of bad but as soon as I can get it to behave I'll go sort those out. Thank you :D

A very grateful celandine
  • UPSGuy
  • Lurker ಠ_ಠ
  • Web Master
  • User avatar
  • Posts: 2733
  • Loc: Nashville, TN

Post 3+ Months Ago

You're welcome. If you run into more trouble, give me a shout.

Post Information

  • Total Posts in this topic: 4 posts
  • Users browsing this forum: No registered users and 67 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.