PHP pages won't load (sometimes)

  • natas
  • PHP Ninja
  • Proficient
  • natas
  • Posts: 308
  • Loc: AFK

Post 3+ Months Ago

Hey guys. Been a while since I last visited! I really need some help.

I just got finished with a rough design for my site. You can visit it at decklocker dot com

It loads just fine and everything looks ok... most of the time. My problem is that every once in a while I get an error message stating that there was a script error and the page doesn't load. (even though I haven't changed anything).

What could be the cause of this? I've contacted POWWeb for support, but it's been 3 days. ugh.
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • joebert
  • Fart Bubbles
  • Genius
  • User avatar
  • Posts: 13503
  • Loc: Florida

Post 3+ Months Ago

Have you checked your sites error logs, as the notice mentions ?

I get the message every time I access one of the links with a php extension on the filename. It looks like a custom error handler used by your host that sends the visitor that generic message and puts any useful information in private error logs.
  • natas
  • PHP Ninja
  • Proficient
  • natas
  • Posts: 308
  • Loc: AFK

Post 3+ Months Ago

[Thu Jun 3 20:40:08 2010] [error] Apache::SubProcess exec of /opt/users/pow/j/e/pow.jefflsimpson/php/php failed

EDIT: [Thu Jun 3 20:40:07 2010] [error] [client REMOVED] getpwuid: invalid userid 1804554
  • joebert
  • Fart Bubbles
  • Genius
  • User avatar
  • Posts: 13503
  • Loc: Florida

Post 3+ Months Ago

That's a new one for me. Taking a shot in the dark here, I'm wondering if maybe a PHP file is missing execute permissions, or the write permission on the file is too broad. (as in writable by group/other in addition to owner)

// Edit -- Your edit definitely makes me wonder about the owner of the files and their permissions. I'd start by going through them if I were you.
  • natas
  • PHP Ninja
  • Proficient
  • natas
  • Posts: 308
  • Loc: AFK

Post 3+ Months Ago

The only thing i have on there is a phpbb3 forum but that was included with my hosting package and all I've done there is modify the CSS to fit my site.

And the live feed of the oil spill is embedded so I don't think that would cause problems...

Other than that it's all hand coded by me.
  • natas
  • PHP Ninja
  • Proficient
  • natas
  • Posts: 308
  • Loc: AFK

Post 3+ Months Ago

UPDATE:

I found something in my CGI "tmp" folder..
bunch of files which looked like open sessions. they held no info so I got to wondering. Then I remembered I was trying to work on a login script and opened a few sessions and don't remember closing them out.

Could that be the problem?
  • joebert
  • Fart Bubbles
  • Genius
  • User avatar
  • Posts: 13503
  • Loc: Florida

Post 3+ Months Ago

Well, today the index.php, news.php, etc links actually load for me instead of going directly to that error. I dare say whatever you did, fixed it.

I was going to mention how strange I thought it was that when I accessed the site with / on the end, I got a page, but accessing index.php was giving me an error. It made me wonder what your DirectoryIndex page actually is as index.html gives me a 404 response.
  • natas
  • PHP Ninja
  • Proficient
  • natas
  • Posts: 308
  • Loc: AFK

Post 3+ Months Ago

It did that for me also. the index page is only index.php. it is set up to access the index.php file whether u use the / or type in /index.php I didn't put an "index.html" in the folder, so I couldn't figure it out either.

I deleted those files in the "tmp" directory and things seem to be working better.

I appreciate the help joebert. If u hadn't have suggested to start digging through the files...

Anyway, it seems to be working a lot better. I have an open ticket with POWWeb tech support (who are totally lost still). Guess I should close it out.

Post Information

  • Total Posts in this topic: 8 posts
  • Users browsing this forum: No registered users and 48 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.