Scrollable Divider not working in Safari

  • bradymills
  • Beginner
  • Beginner
  • User avatar
  • Posts: 58
  • Loc: Nashville, TN

Post 3+ Months Ago

Can someone tell me why a scrollable divider isn't working in safari? It works perfectly in IE. Is it not supported? Is there something I can do to force safari to accept it?

Thanks,
Brady

Here's the CSS:
Code: [ Select ]
#indexcontent {
    font: 80% bold Times New Roman, Times, serif;
    text-align: justify;
    color: #333333;
    width: 535px;
    height: 300px;
    padding-right: 10px;
    padding-bottom: 10px;
    overflow: -moz-scrollbars-vertical;
    overflow-x: hidden;
    overflow-y: scroll;
    scrollbar-arrow-color: #666666;
    scrollbar-track-color: #FFFFFF;
    scrollbar-shadow-color: #666666;
    scrollbar-slider-color: #FFFFFF;
    scrollbar-face-color: #FFFFFF;
    scrollbar-highlight-color: #FFFFFF;
    scrollbar-darkshadow-color:#FFFFFF;
    scrollbar-3dlight-color: #666666;
}
  1. #indexcontent {
  2.     font: 80% bold Times New Roman, Times, serif;
  3.     text-align: justify;
  4.     color: #333333;
  5.     width: 535px;
  6.     height: 300px;
  7.     padding-right: 10px;
  8.     padding-bottom: 10px;
  9.     overflow: -moz-scrollbars-vertical;
  10.     overflow-x: hidden;
  11.     overflow-y: scroll;
  12.     scrollbar-arrow-color: #666666;
  13.     scrollbar-track-color: #FFFFFF;
  14.     scrollbar-shadow-color: #666666;
  15.     scrollbar-slider-color: #FFFFFF;
  16.     scrollbar-face-color: #FFFFFF;
  17.     scrollbar-highlight-color: #FFFFFF;
  18.     scrollbar-darkshadow-color:#FFFFFF;
  19.     scrollbar-3dlight-color: #666666;
  20. }


Here's the HTML:
Code: [ Select ]

<div id="indexcontent">

<!--Main content Goes here--->

<p>Content, blahblahblah</p>

 <!--Main Content Ends here--->
</div>    
  1. <div id="indexcontent">
  2. <!--Main content Goes here--->
  3. <p>Content, blahblahblah</p>
  4.  <!--Main Content Ends here--->
  5. </div>    
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • bradymills
  • Beginner
  • Beginner
  • User avatar
  • Posts: 58
  • Loc: Nashville, TN

Post 3+ Months Ago

I found a solution to this, just thought I'd share -- in case someone else had this problem. I'm still learning lots of stuff -- so a huge knowledge base like this site -- always comes in useful...

I simply replaced overflow - x, overflow-y, etc... with

overflow: auto;
overflow-y: auto;
overflow-x: hidden;

seems to work fine now... in safari, ie, etc...
  • tiranhay
  • Born
  • Born
  • tiranhay
  • Posts: 1

Post 3+ Months Ago

Thanks alot brady!
It works perfectly.
  • mayumi
  • Born
  • Born
  • mayumi
  • Posts: 1

Post 3+ Months Ago

Thanks bradymills! Worked perfectly for my problem. Keep on sharing. ;)

Post Information

  • Total Posts in this topic: 4 posts
  • Users browsing this forum: No registered users and 35 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.