sitemap submission problem

  • ENERGY BOD
  • Born
  • Born
  • ENERGY BOD
  • Posts: 2

Post 3+ Months Ago

Greetings all from a newbie (yes that means here comes an embarrassingly basic question!)

I've constructed a site (a basic site - 85 pages and nothing fancy) and I've done a lot of recoding for SEO purposes - renaming pages, images etc, then making the broken links good again etc, and validated it.

I've, surfed around a bit and downloaded something that generated a sitemap AND which included a guide as to how to submit the sitemap to google (A sitemap is a must because I have 70 pages which link to a basic 15 and which do not link the other way).

The sitemap looked ok and has an xml extension which i uploaded to my root directory. I then informed google that the sitemap was there and was looking forward to a well deserved breather when i got this error message:

General HTTP error: 404 not found
We encountered an error while trying to access your sitemap. Please ensure your sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.

This was after (on the google submission window):
1) clicking Add general sitemap
2) typing in sitemap url i.e. http://www.root.com/sitemap.xml

Clearly it's saying that either i've done it wrong or it can't find it. Submission should have been the easiest thing of all. I even tried uploading a simple text file with a complete url list and got the same error message. Any ideas?
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • righteous_trespasser
  • Scuffle
  • Genius
  • User avatar
  • Posts: 6230
  • Loc: South-Africa

Post 3+ Months Ago

I'd suggest letting GSiteCrawler build the SiteMap for you ... It's freeware and it works ...
  • ENERGY BOD
  • Born
  • Born
  • ENERGY BOD
  • Posts: 2

Post 3+ Months Ago

After a night's sleep, I've solved it. Talk about basic!
When in the google submission window, i was invited to type in the url I thought i had to type ALL of the url in i.e. starting from http etc. But to the side of window this had already been done the prompt, therefore, was from the root directory. In my tired state, I thought the prog was just being helpful and I typed the whole thing in from http: etc.

Post Information

  • Total Posts in this topic: 3 posts
  • Users browsing this forum: No registered users and 83 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.