table width=" 100% " - not really 100%?

  • Nem
  • Guru
  • Guru
  • Nem
  • Posts: 1243
  • Loc: UK

Post 3+ Months Ago

Hey i created a table thats 100%... but it has a gap on the right hand side.

when i press F5 then it fills the gap (100%).... whats the prob?
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • digitalMedia
  • a.k.a. dM
  • Genius
  • User avatar
  • Posts: 5149
  • Loc: SC-USA

Post 3+ Months Ago

Could you post the code for the HTML and CSS?
  • Nem
  • Guru
  • Guru
  • Nem
  • Posts: 1243
  • Loc: UK

Post 3+ Months Ago

I got another problem.... The table row keeps enlarging...

I give a screenshot as its a secure area...

one sec
  • Nem
  • Guru
  • Guru
  • Nem
  • Posts: 1243
  • Loc: UK

Post 3+ Months Ago

Image

here
  • Nem
  • Guru
  • Guru
  • Nem
  • Posts: 1243
  • Loc: UK

Post 3+ Months Ago

Code: [ Select ]
<table width=98% border=0 align=center cellpadding=0 cellspacing=0>
          <tr>
           <td width=29% height=47> <table width=100% height=100% border=0 cellpadding=0 cellspacing=0>
             <tr>
              <td height=16 valign=top bgcolor=#333333> <div align=center><strong><font color=#CCCCCC size=2 face=Verdana, arial, helvetica, sans-serif>Statistics</font></strong></div></td>
             </tr>
             <tr>
              <td height=114 valign=top bgcolor=eeeeee>&nbsp;</td>
             </tr>
            </table></td>
           <td width=19>&nbsp;</td>
           <td width=70% valign=top> <div align=center>
             <table width=100% height=100% border=0 cellpadding=0 cellspacing=0>
              <tr>
               <td height=16 valign=top bgcolor=#333333> <div align=center><strong><font color=#CCCCCC size=2 face=Verdana, arial, helvetica, sans-serif>Other
                 Information</font></strong></div></td>
              </tr>
              <tr>
               <td height=28 valign=top bgcolor=eeeeee><table width=100% border=0 cellspacing=0 cellpadding=0>
                 <tr>
                  <td height=113 align=left valign=top>&nbsp;</td>
                 </tr>
                </table></td>
              </tr>
             </table>
            </div></td>
          </tr>
         </table>
  1. <table width=98% border=0 align=center cellpadding=0 cellspacing=0>
  2.           <tr>
  3.            <td width=29% height=47> <table width=100% height=100% border=0 cellpadding=0 cellspacing=0>
  4.              <tr>
  5.               <td height=16 valign=top bgcolor=#333333> <div align=center><strong><font color=#CCCCCC size=2 face=Verdana, arial, helvetica, sans-serif>Statistics</font></strong></div></td>
  6.              </tr>
  7.              <tr>
  8.               <td height=114 valign=top bgcolor=eeeeee>&nbsp;</td>
  9.              </tr>
  10.             </table></td>
  11.            <td width=19>&nbsp;</td>
  12.            <td width=70% valign=top> <div align=center>
  13.              <table width=100% height=100% border=0 cellpadding=0 cellspacing=0>
  14.               <tr>
  15.                <td height=16 valign=top bgcolor=#333333> <div align=center><strong><font color=#CCCCCC size=2 face=Verdana, arial, helvetica, sans-serif>Other
  16.                  Information</font></strong></div></td>
  17.               </tr>
  18.               <tr>
  19.                <td height=28 valign=top bgcolor=eeeeee><table width=100% border=0 cellspacing=0 cellpadding=0>
  20.                  <tr>
  21.                   <td height=113 align=left valign=top>&nbsp;</td>
  22.                  </tr>
  23.                 </table></td>
  24.               </tr>
  25.              </table>
  26.             </div></td>
  27.           </tr>
  28.          </table>
  • Foxy
  • Guru
  • Guru
  • User avatar
  • Posts: 1038
  • Loc: places..

Post 3+ Months Ago

did you have to triple post -.- instead of edit.
  • rtm223
  • Mastermind
  • Mastermind
  • User avatar
  • Posts: 1855
  • Loc: Uk

Post 3+ Months Ago

I don't know if it's the cause of the problem but you should sort out your nesting first off, you've got a <tr> directly inside a <td>, and thats not right. It may not be causing the problem, but it's certainly not gonna do you any favours. This is on the 3rd/4th line

It's hard to get your tags nested when you use far too many of them :P
  • Nem
  • Guru
  • Guru
  • Nem
  • Posts: 1243
  • Loc: UK

Post 3+ Months Ago

sorry foxy, i treat this like msn messenger for some reason.

Also, quick reply box tempts me :P

Post Information

  • Total Posts in this topic: 8 posts
  • Users browsing this forum: No registered users and 39 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.