FF Unexplainable Gap

  • veindesigns
  • Newbie
  • Newbie
  • veindesigns
  • Posts: 8

Post 3+ Months Ago

Hi, im currently helping my work build there new website, i have good knowledge of HTML & CSS but i'm rusty on how to sort out compatabilty issues,

I'm using a DHTML Menu Builder which (So they say) is compatible with all browsers which it did seem to be but now i'm thinking this may not be the case, as it seems to be creating a problem in FF, although this may not be the case and it may just be my inexperiance.

if you look at this page

http://www.carl-robinson.co.uk/CHS/Concept2.html

your'll see that it behaves differently in FF3 then IE7

can someone please help me here?

the css is here...

http://www.carl-robinson.co.uk/CHS/Main2.css

and the JS that the menu builder made are here...

http://www.carl-robinson.co.uk/CHS/Menu/Script/

Thanks in advance :)

Vein

P.S i know it doesn't appear properly in IE6 and below but thats for another day!
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • HongKongPhooey
  • Student
  • Student
  • User avatar
  • Posts: 86
  • Loc: Liverpool

Post 3+ Months Ago

Correct link for the css is:

http://www.carl-robinson.co.uk/CHS/main2.css

just to save anyone else trying to work it out :)


I'll have a look and see if I can see anything wrong
  • jameson5555
  • Bronze Robot
  • Bronze Member
  • User avatar
  • Posts: 575
  • Loc: Phoenix, AZ

Post 3+ Months Ago

I've run into this same thing before. I'm pretty sure it's a margin/padding cross-browser interpretation thing, but the easiest way to fix it is to just add a line break at the top of your content area:
Code: [ Select ]
<div id="mainContent"><br/>
    <div id="Text">
  1. <div id="mainContent"><br/>
  2.     <div id="Text">
  • HongKongPhooey
  • Student
  • Student
  • User avatar
  • Posts: 86
  • Loc: Liverpool

Post 3+ Months Ago

I didn't download all the scripts etc, so I don't know if this will work, but ...

try taking the height off the "#dmbTB1ph" div. From the skeleton I had here, it looked like it might work
  • veindesigns
  • Newbie
  • Newbie
  • veindesigns
  • Posts: 8

Post 3+ Months Ago

jameson5555 wrote:
I've run into this same thing before. I'm pretty sure it's a margin/padding cross-browser interpretation thing, but the easiest way to fix it is to just add a line break at the top of your content area:
Code: [ Select ]
<div id="mainContent"><br/>
    <div id="Text">
  1. <div id="mainContent"><br/>
  2.     <div id="Text">



wow thanks that works!!

thanks alot guys! and yeah sorry about the wrong link!

:D

thanks again!

Post Information

  • Total Posts in this topic: 5 posts
  • Users browsing this forum: No registered users and 62 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.