my website wont pass W3C validation

  • ikillthescene
  • Born
  • Born
  • ikillthescene
  • Posts: 3

Post 3+ Months Ago

i have a single line of code
Code: [ Select ]
<div id="content">
 <hr align="left" width="700" size="1" noshade="noshade" />Howdy.<br />
 <img src="images/me.jpg" alt="me" /><td height="700" colspan="2" align="center">&nbsp;</td>
</div>
  1. <div id="content">
  2.  <hr align="left" width="700" size="1" noshade="noshade" />Howdy.<br />
  3.  <img src="images/me.jpg" alt="me" /><td height="700" colspan="2" align="center">&nbsp;</td>
  4. </div>



and W3C says:

Line 136, Column 82: document type does not allow element "td" here

Code: [ Select ]
…ages/me.jpg" alt="me" /><td height="700" colspan="2" align="center">&nbsp;</td>




The element named above was found in a context where it is not allowed. This could mean that you have incorrectly nested elements -- such as a "style" element in the "body" section instead of inside "head" -- or two elements that overlap (which is not allowed).

One common cause for this error is the use of XHTML syntax in HTML documents. Due to HTML's rules of implicitly closed elements, this error can create cascading effects. For instance, using XHTML's "self-closing" tags for "meta" and "link" in the "head" section of a HTML document may cause the parser to infer the end of the "head" section and the beginning of the "body" section (where "link" and "meta" are not allowed; hence the reported error).


if anyone can help me with this it would be much much appreciated!!
  • joebert
  • Fart Bubbles
  • Genius
  • User avatar
  • Posts: 13504
  • Loc: Florida

Post 3+ Months Ago

I'm leery about making a suggestion without seeing the rest of the pages code. My first instinct is to say replace this

Code: [ Select ]
<td height="700" colspan="2" align="center">&nbsp;</td>


I'm not quite sure what's happening with colspan in that snippet though, so I don't know what kind of width a replacement element might need.
  • ikillthescene
  • Born
  • Born
  • ikillthescene
  • Posts: 3

Post 3+ Months Ago

thank you!

that cleared it up
  • joebert
  • Fart Bubbles
  • Genius
  • User avatar
  • Posts: 13504
  • Loc: Florida

Post 3+ Months Ago

Did you just remove it, or replace it with something else?
  • ikillthescene
  • Born
  • Born
  • ikillthescene
  • Posts: 3

Post 3+ Months Ago

joebert wrote:
Did you just remove it, or replace it with something else?



removed it and it worked fine.

Post Information

  • Total Posts in this topic: 5 posts
  • Users browsing this forum: No registered users and 21 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.