SITE REVIEW: 4Webmasters

  • gonetwork
  • Novice
  • Novice
  • User avatar
  • Posts: 24
  • Loc: Australia

Post 3+ Months Ago

Hi all,
I just finished the new design for 4webmasters and also added a new forum, it has been down for 12mths and decided to put it up again.

the URL:
http://www.4webmasters.us

and the forum:
http://www.4webmasters.us/forum

The site still has alot of content to be added, so if you have any ideas of what I can ad, please let me know.

I would also like feedback on the design and the site content so far.

The site has been up for a couple of years but now I am getting right back into it, I am always updating and trying to expand. It was getting alot of hits from google and links so I decided to go hard and start paying more attention to this site.

Thanks for looking.
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • SharkShark
  • Guru
  • Guru
  • User avatar
  • Posts: 1013
  • Loc: Living In Today

Post 3+ Months Ago

Good Job. I like the navigation, it looks good:D, and loaded up fast. The whole site loaded quickly and look very clean and proffesional. You are right, it does need more content, but in the meantime, it looks good.
  • vidiot
  • Born
  • Born
  • vidiot
  • Posts: 3
  • Loc: OC

Post 3+ Months Ago

Looks good, I like it. Maybe try a rollover affect on the top buttons.
  • smith_zach89
  • Student
  • Student
  • smith_zach89
  • Posts: 71
  • Loc: Germany

Post 3+ Months Ago

It is an excellent site, but the one thing that stood out and needed to be improved was the menu. Rather than just having the text change color, why not have the entire button rollover? Maybe even center the text. It's something to play with.

The colors all go together nicely, and about the only other thing I can see that could be improved is the logo on the top of the page. Have it match the background on the edges or slowly fade to match it, or have the background match the logo. Having those lines where the color changes is slightly tacky, but not very noticeable.

Overall I give your site a 9 out of 10.
  • gonetwork
  • Novice
  • Novice
  • User avatar
  • Posts: 24
  • Loc: Australia

Post 3+ Months Ago

Thankyou for your feedback, and the 2 points you mentioned are exactly the same things I have been thinking about changing, and adding more content of course. Yes, I also thought the logo image was not 'cut out' good enough in photoshop from the white background is was originally on, I noticed that right away actually, and put it on my to do list. I have also been playing around with the left nav bar as I also thought this was too plain. I was originally trying to add a border to the right hand side of it to sort of 'close it off' but could not get it right. I am actually thinking of making graphics for each of the buttons instead, this will make it look more attractive i think. I just wish I could get the border to work, it really would look better if there was a dark blue line down the whole right hand side of the nav bar to close it off from the content area. Well, I will work on this within the next 2 weeks, as It looks good now, and I am trying to concernrate on adding content first. The logo I will be fixing within 24 hours though.

Thanks again for your feedback, If anyone else can check it out I would love to hear what you have to say.

Also, can anyone tell me how it looks in different browsers (other than IE6) and also a bigger screen res than 800x600 (is it centered and does the background color look good and fit it with the template etc etc etc)...

Thanks All, have a great weekend.


Peace!
  • Nucleo
  • SausagePorkPie
  • Mastermind
  • User avatar
  • Posts: 2297
  • Loc: UK - England

Post 3+ Months Ago

g'day, thought i would review :D

oky doky

the site looks great, but i also have to say something about the navigation on the left.
remove the underline from it, it doesn't look right at all.

where the mailing list is, and the mouseover goes orange, it doesn't queit look right, or suit the site.

the top header looks very cool, but for the some reason the main body of the site doesn't match 100%, perhaps altering colours.

the text under each image is very distorted, and could be made much more legible

thanks, Nucleo
7/10

Post Information

  • Total Posts in this topic: 6 posts
  • Moderator: Website Reviewers
  • Users browsing this forum: No registered users and 21 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.