SITE REVIEW: Frantic-Designs

  • Purple Haze
  • Novice
  • Novice
  • User avatar
  • Posts: 24

Post 3+ Months Ago

http://www.frantic-designs.com

Hi there, it's been a little while since i've been to ozzu. Some people may remember my old site the-fusion. Well i have learned quite a lot since then, and i have put my new found skills into website design.

All feedback is welcomed negative and positive but, the content is not yet up, so i only really want feedback on the actual design of the site please.

Thanks people. :)
  • justbishop
  • Novice
  • Novice
  • User avatar
  • Posts: 20
  • Loc: Greenville, SC

Post 3+ Months Ago

The tabled layout looks like it'll be nice, but none of the graphics are coming up for me :? (Or maybe that's what you meant by the content not being up yet?)

I look forward to seeing what it looks like in the end, though.

BTW, are those your prices for design only? Just curious.
  • Purple Haze
  • Novice
  • Novice
  • User avatar
  • Posts: 24

Post 3+ Months Ago

Thanks for your time.
No they're not my prices, in fact i am going to have to do some research from other companies. I just put them in because i didn't know what to charge, have any ideas of what the usual price is?

And yea the graphics and stuff, it's all going to be filled with content and links and all the works, it's just it's exam time at the moment so i have to do a bit at a time. :roll:

But once again thanks for your review.

cheers.

EDIT: Don't any graphics show up for you?
  • rtm223
  • Mastermind
  • Mastermind
  • User avatar
  • Posts: 1855
  • Loc: Uk

Post 3+ Months Ago

Well, we have a little problem you see. Your images don't display at all, I just get a whole bunch of broken images symbols. Now I went into the images folder and I can see all the files are there, but if I try to view them it 404's on me. Quite strange TBH.

No matter, I can review without seeing the site, I will review your code like I always do ;) . You have too many spacer gifs (one is too many IMO, but you have <b>far</b> to many). If fact about a third of your code is taken up with spacer gif img tags.

Plenty of validation errors:
http://validator.w3.org/check?uri=http: ... /home.html
Many less than microsoft, but that is no excuse.

You have also chosen a bizarre page size. Why 899px wide? Personally, I would not create a fixed width site wider than 750ish - plenty of people on 800x600 res. But 899 doesn't even fit any <b>proper</b> resolution.

Oh, and I will add the obligatory icky tables comment - especially as they are nested tables - and it looks very much like you plan to have text on the images, and an iframe. I would advise against both.

And I don't like splash pages much either.
  • Purple Haze
  • Novice
  • Novice
  • User avatar
  • Posts: 24

Post 3+ Months Ago

Well that's really strange. :?
I can't make that out, all images are pointing towards the right place and everything is as it should be. Well clearly not.... i really don't know. The weird thing is it works perfect for me.
  • justbishop
  • Novice
  • Novice
  • User avatar
  • Posts: 20
  • Loc: Greenville, SC

Post 3+ Months Ago

Nope, no graphics at all. Do you have hotlink protection set up on your host, by any chance? I had a problem with that when I activated mine, and had to specify to allow direct requests for images to show up on my own pages.

(And about the pricing, that's why I was asking YOU, lol! I'm doing a small buisness-y site for my father-in-law, and haven't the foggiest what to charge him.)
  • rtm223
  • Mastermind
  • Mastermind
  • User avatar
  • Posts: 1855
  • Loc: Uk

Post 3+ Months Ago

well, curiouser and curiouser.

If you are using firefox, right click on the images and select view image.
Then th image will cache and you can see it on the normal page......

any Ideas why this might be people......


//EDIT: ouch! how large is the combined filesize for that page!? 300k :shock: with NO flash, damn thats crazy. You should really look into optimising images for the internet. Seriously, you've got jpegs set to 99% quality :shock:
  • Purple Haze
  • Novice
  • Novice
  • User avatar
  • Posts: 24

Post 3+ Months Ago

Yes i do have hotlink protecton setup but.. i have just added the domain http://www.frantic-designs to it's allow list. The other thing maybe is because i have free hosting with sonnexhosting, and i can only have one domain the account is setup with http://www.the-fusion.co.uk, but i have used frantic-designs.com as an addon domain. I'm not sure if this would affect anything as i havn't needed to use it before.
  • justbishop
  • Novice
  • Novice
  • User avatar
  • Posts: 20
  • Loc: Greenville, SC

Post 3+ Months Ago

Yep, that's exactly what happened to me. I started out with justbishop.com, and had fangirlonlline.com parked. From then on, I had to set my hotlink thing to allow direct requests from anywhere just to get my images to show up on a Fangirl page (even though I put the url on my allow list.)
  • Purple Haze
  • Novice
  • Novice
  • User avatar
  • Posts: 24

Post 3+ Months Ago

Ok i disabled it, would you check it for me please?
thanks.
  • justbishop
  • Novice
  • Novice
  • User avatar
  • Posts: 20
  • Loc: Greenville, SC

Post 3+ Months Ago

Wheee! Working great now! Lovelovelove the graphics...and I'm not usually one for the squiggly textured stuff :lol:

I think the navigation is going to work out wonderfully, once you get all of your pages up!

ETA: Because of your tagline, I'm going to have "Bust a Move" by Young MC in my head all day...I hope you're proud of yourself, lol!
  • Purple Haze
  • Novice
  • Novice
  • User avatar
  • Posts: 24

Post 3+ Months Ago

Wicked thank you both for your help, it has come in very handy i wouldn't have even known if you hadn't have told me. Thank you ever so much. :)

Yea i have some pretty good stuff coming soon, just a matter of time now though.
  • jlknauff
  • Expert
  • Expert
  • User avatar
  • Posts: 502
  • Loc: Florida

Post 3+ Months Ago

:shock: Images loaded fine for me...I kinda wish they hadn't. No offense, but what a way to abuse the bevel/embose command in PS. God I wish that feature had never been added to the program. IMO the site is really busy and could be toned down (& lightened) quit a bit.
  • Purple Haze
  • Novice
  • Novice
  • User avatar
  • Posts: 24

Post 3+ Months Ago

Ok cool fair enough. But it's only the banner and bottom affiliate strip that are bevelled. :?
  • Andy Abbott
  • Newbie
  • Newbie
  • Andy Abbott
  • Posts: 10
  • Loc: London

Post 3+ Months Ago

Looking at the picture, an idea comes to mind.

What if you had the people at the bottom doing poses to be the menu.
  • philgill
  • Novice
  • Novice
  • User avatar
  • Posts: 24

Post 3+ Months Ago

Well where do i start?
Your graphics are good but have you thought about seo or what your visitors will be looking for?
Firstly what purpose does the splash page have. I found no real purpose at all other than because you think it looks good (which it does) but customers and searchengines will hate it. Get rid of the splash page.
Secondly does your banner and nav menu have to be so big? I'm on a large resolution setting and most of the important info is hidden under the viewable screen. Reduce the banner and make your menu a little slimmer, the more people can see straight away the more they will want to look further. Personally if i had found your site i would have left immediatly for several reasons. The splash page, the lack of info on the viewable screen, the fact that some of your graphics have been pushed out or down (botom of the page).
From an seo point of view your lost. Your selling a product and in a very competitive market. You will have to demonstrate to the user that you know all about this stuff so maybe a couple of hours a week dedicated to learning about that stuff would pay of big for you.
Thats enough for now. Hope that this has helped a little.
You have some talent for creating graphics there, build on that with good usability and seo techniques.
Phil
  • eppskevin
  • Newbie
  • Newbie
  • User avatar
  • Posts: 6
  • Loc: Durham, NC

Post 3+ Months Ago

Very nice!! I like the art work, I can tell that you used Photoshop for most of the art, didn't you?
  • Purple Haze
  • Novice
  • Novice
  • User avatar
  • Posts: 24

Post 3+ Months Ago

Thank you for that feedback phil very interesting. Well it has a new design now, which i feal looks a lot more cleaner easier to understand and gets to the point. Yes i used photoshop for my old design and for my new one. I am now working hard at SEO, but i am new at it so i have a long way to go yet.

Once again thanks for feedback.

:wink:
  • _sevenone
  • Newbie
  • Newbie
  • _sevenone
  • Posts: 7

Post 3+ Months Ago

I would lose the bevel and emboss completely. Definitely from the text in your nav and at the bottom of the page. It's illegible in some places. Also if you click on "Links" your graphics become misaligned at the top. You also need some examples of your work somewhere and I would run a spellcheck asap. It's a nice site though, good luck with it m8.

Post Information

  • Total Posts in this topic: 19 posts
  • Moderator: Website Reviewers
  • Users browsing this forum: No registered users and 3 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.