SITE REVIEW: Grim Designs V3-Graphics design forum

  • Salohcin
  • Born
  • Born
  • Salohcin
  • Posts: 4
  • Loc: Lower Ohio

Post 3+ Months Ago

Hey there everyone I would a site review for my Dot Com and Forums...

website: http://www.grim-designs.com/main.htm
Forums: http://invisionfree.com/forums/grim_graphics

This site was recently turned over to me approximately 3 months ago by a friend who went off to college and had no more time to continue maintainance on the site.....at the time of turnover there were around 130 members and we have since then grown alot.....I have put alot of work into this site as have my other partners and I would really appreciate a review of the forums and main site...im looking for some constructive criticism as to what could be changed to get some more traffic there or just anything at all that you think might help....also i thought you might want to know we are a graphics design forum and all of the buttons and banners for the site were made by myself since taking it over....

thanks for your time and i appreciate any help at all....

Nick
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • 613flavah
  • battlestar
  • Web Master
  • User avatar
  • Posts: 3289
  • Loc: Hurricane...

Post 3+ Months Ago

Hi Salohcin. Here are some comments:

- Takes too long to load, optimize your graphics.

- Doesn't display properly in FF. Did you test in various browsers?

- In the Members list, when I click on anyone's profile but the retired admin's I can't read the text it seems to be the same colour as the background.

- When I click on Galleries, the header graphic disappears. Keep your site consistent.

- I don't like how your forums are set up at the top. I can barely see the thread list even on my 24 inch monitor I have to scroll down because you've got 2 banner graphics at the top. Stick to one or make 2 smaller ones.

- In the Forums -> Registration form, under the Security Code Confirmation, I think that the code is displaying wrong, I get a number that is spaced out tremendously from the rest of them? I just refreshed and now I get a broken link. I just refreshed and it's working fine now. You may want to take a closer look at the code there. Plus ithe gifs look terrible. Try at least using the same background colour for the gifs as is on the forum so it blends in better and doesn't look so botchy.

- No META data!!!

1 more thing, what is that at the bottom of the registration page? A shout outs box? where ppl submit their nick and URL and email and a comment and it gets displayed in the black box? Why do you have it there? I think it should be moved to a better location and not on the registration page.

Hope all this helps
  • MrChico
  • Newbie
  • Newbie
  • MrChico
  • Posts: 7

Post 3+ Months Ago

Hi Nick,

The site looks really good and really professional.

You're obviously very talented because the graphics are simply amazing. I also appreciate the fact that you've used easy to read fonts. Sites like yours tend to use small unreadable fonts that supposedly look stylish, but are just irritating. You've chosen a much better font (Arial 12), that's easy on the eyes.

I've downloaded one of your wallpapers, and I now have it on my desktop.

I do agree though that your graphics take too long to download. I have a fast connection and I'm not used to waiting more than 3 seconds for a page to download, and yours took longer. If you optimize your graphics they'll load much faster, and there won't even be any visible difference in the quality.

Other then that there isn't much more I can think of to add. The site is amazing, all the colors blend together perfectly. You've done a teriffic job.

Good luck,
MrChico.
  • vdesigns
  • Newbie
  • Newbie
  • vdesigns
  • Posts: 6
  • Loc: india

Post 3+ Months Ago

hi Salohchin

you have made a jazzy site. the navigation is easy. I liked the metallic effect on the whole.
  • Truce
  • Guru
  • Guru
  • Truce
  • Posts: 1477
  • Loc: Washington DC

Post 3+ Months Ago

I second the FF (FireFox/Mozilla) issue. Text is black on black so I must highlight it to read it!

The vertical lines that you have set as a background image don't look like they belong their and they definately don't add anything to the site.

The nav is done in orange and yellow and other parts of the site (ie. text) is blue and other various colors. I would pick 3-4 colors and match the site to that color scheme.

Great use of CSS and DIV tags though!
  • webinv
  • Graduate
  • Graduate
  • webinv
  • Posts: 110

Post 3+ Months Ago

Some of the images on the right side under "Links" do not work. Only two of the images even loaded for me. The site does load fairly slow, but it is okay overall.
  • CWilson04
  • Newbie
  • Newbie
  • CWilson04
  • Posts: 10

Post 3+ Months Ago

Site is alright and I am crackin up over the pumpkin butt picture lol. I like your top image.

Post Information

  • Total Posts in this topic: 7 posts
  • Moderator: Website Reviewers
  • Users browsing this forum: No registered users and 10 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.