SITE REVIEW: poweroftheweb.com

  • bilgil
  • Newbie
  • Newbie
  • bilgil
  • Posts: 12
  • Loc: Springfield, Mo

Post 3+ Months Ago

Whats Up,

I own a small SEO and internet marketing firm. I personally am new at web developing. Any web design projects my company recieved in the past got contracted out. I redesigned my site (myself) a couple weeks ago and would like to hear some feedback. My knowledge is only a little CSS so that is why I am not utilizing any other methods like JavaScript, PHP, and so on.

http://www.poweroftheweb.com
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • righteous_trespasser
  • Scuffle
  • Genius
  • User avatar
  • Posts: 6230
  • Loc: South-Africa

Post 3+ Months Ago

504 Gateway Timeout
  • XHA
  • Novice
  • Novice
  • XHA
  • Posts: 21

Post 3+ Months Ago

Well, the design is okay - but I expect something a little more decent from an 'internet marketing company'. It's all a bit wishy-washy and unsuitable for such a company.

The source is nice and clean, but I'd suggest defining all styles in your CSS. I see you have horizontal alignment properties on all/most of your h1 tags.

But for me, your atrocious spelling puts me right off. I mean "Less than 5% of people will look passed the third page of a search engine," << PASSED? I think you mean 'past'. Also not the way I would phrase a statement like this...

This is just careless for a professional company!

Otherwise not bad, just not the design I'd choose for an internet marketing company. (personally, I don't like the colours or layout either...but hell, this is just opinion).
  • righteous_trespasser
  • Scuffle
  • Genius
  • User avatar
  • Posts: 6230
  • Loc: South-Africa

Post 3+ Months Ago

Aaah got it ...

Maybe you would want to add some rollovers to the left hand side menu (our services)

I'm very glad to see that your page is valid according to the w3c ... there's just one warning ... there isn't a semicolon after the "&copy" at the bottom of your page ... It should be "&copy;" ...

I also think your main nav would look better if you remove that gray area just between it and the body ...

On the "services" page there is a huge gap between "... grow with the future" and the bottom of the page ... I'm using IE7 ... on the portfolio page aswell ... Okay now I see that it's on every page except the home page ...

Your top logo is really lagging something ... It's tiny and the rest of the width is gray ... Not very exciting ...

Also you could actually disable the link of the page that the user is on at the moment, for example if I am on the "services" page the "services" link could be disabled ...

In the "our services" block there is a nice gap between the heading and the content of that block ... but in the "our friends" block there isn't ... And in the "our friends" block the text goes over the border of the block on the right hand side ...
  • bilgil
  • Newbie
  • Newbie
  • bilgil
  • Posts: 12
  • Loc: Springfield, Mo

Post 3+ Months Ago

Thanks for the comments. My inaccurate spelling is embarrassing. I know the logo needs a ton of work. I am trying to come up with something a little better. I am going to clean up the site and work on a better logo today.

Thanks agin for your comments.
  • bilgil
  • Newbie
  • Newbie
  • bilgil
  • Posts: 12
  • Loc: Springfield, Mo

Post 3+ Months Ago

Hey everybody,

I did a few modifications to my website. Tell me what you think.
  • Bogey
  • Genius
  • Genius
  • Bogey
  • Posts: 8399
  • Loc: USA

Post 3+ Months Ago

Nice clean website, pages load fast, images are not bad. Good luck. Your rolling in the right direction.
  • righteous_trespasser
  • Scuffle
  • Genius
  • User avatar
  • Posts: 6230
  • Loc: South-Africa

Post 3+ Months Ago

Something has gone terribly wrong, there is a huge gap between the man nav and the content in IE7 and FF2 ...
  • bilgil
  • Newbie
  • Newbie
  • bilgil
  • Posts: 12
  • Loc: Springfield, Mo

Post 3+ Months Ago

Hello,
I made a few design changes to my website. Wht do you all think?
  • shatter2day
  • Graduate
  • Graduate
  • User avatar
  • Posts: 185
  • Loc: N.Y.

Post 3+ Months Ago

I think righteous tresspasser said this, but the page is much bigger than it needs to be, you have a horizontal scroll bar that really doesn't need to be there...
  • murcielagossi
  • Proficient
  • Proficient
  • User avatar
  • Posts: 457

Post 3+ Months Ago

It looks good on my first monitor (1280x1024) but on my second monitor (1024x768) it looks squished
  • yati_yati
  • Newbie
  • Newbie
  • yati_yati
  • Posts: 7
  • Loc: India

Post 3+ Months Ago

Nice clean looking website, very fast loading. Good work.
  • GiorgosK
  • Novice
  • Novice
  • User avatar
  • Posts: 16
  • Loc: geoland.org > Greece

Post 3+ Months Ago

The header-home background is constrainted to 1280 px width !
and it looks unprofessional.

What about those of us that have higher resolutions, don't make assumptions about higher width resolutions, just minimum resolutions.

Of course you designed this on your monitor (which is probably 1280 in width) but there are people with different monitors

The whole layout being 150px from the left edge of the browser does not appeal to me. Either make it almost attached to the left or make it align in the middle.

The header graphic is very nice I must admit but the choice of the rest of the colors in the page is not what I would call the best choices.
  • etrader
  • Novice
  • Novice
  • User avatar
  • Posts: 25

Post 3+ Months Ago

It's good design

but the white background under the white background of the main body is not eye-catching
  • fitzpatrickbrett
  • Newbie
  • Newbie
  • fitzpatrickbrett
  • Posts: 8
  • Loc: Vienna

Post 3+ Months Ago

The white tabs at the top of the page did not work in my browser, (Internet Explorer) so all I could see was your front page. I can see you are listening to what is said here, passed has changed to beyond. To me, it looked great.
  • 74123
  • Graduate
  • Graduate
  • 74123
  • Posts: 190

Post 3+ Months Ago

I am using FF 2.0.

The website is very nice, clean, and I like it a lot. Very good!

One thing I noticed right off the bat was the tabs, I love them BUT the active tab seems out of place to me. I would put a grey border around the active tab, to kind of tie it in with the border (below the diagonal lines).

This might be kind of hard to explain, but I will try. I am big on keeping a website size down for fast load times (yes, even with the blazing high speeds everyone seems to have)... Your header image is 131KB. WAAAY to big imo. You should optimize it down as low as it will go without losing quality. Next thing you do is cut a small sliver off. See the solid image colours on the right and left side? cut off 1px of that, and make that your header background image.

What that does is make a very small image for your header background (the one the repeats throughout the width of the browser) and it lowers load time. Then you just cut off the excess image of the header.

This will also take away the vertical scroll I am getting, my resolution is 1280*800, and at that resolution, it is simply unacceptable.

Do you get what I'm saying?


I figure for me to get feedback, I should leave some, so please review my website ;-]

Post Information

  • Total Posts in this topic: 16 posts
  • Moderator: Website Reviewers
  • Users browsing this forum: No registered users and 4 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.