SITE REVIEW: Virtual phone numbers

  • alfonko
  • Newbie
  • Newbie
  • alfonko
  • Posts: 8
  • Loc: uruguay

Post 3+ Months Ago

well, the site was pr 4 last pr update... but now it decreased. We are doing our best to make it google frindly and we are achieving some good results. But we would like to have some advices from you peaople. And check the christmas special offer (get a free number) you may found the deal interesting :)

the site http://www.jetnumbers.com

regards
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • jameson5555
  • Bronze Robot
  • Bronze Member
  • User avatar
  • Posts: 575
  • Loc: Phoenix, AZ

Post 3+ Months Ago

I think the site looks nice and professional and explains itself clearly and plainly. The only aesthetic thing I noticed was that the gray text in the top center that ends with "with a few keystrokes." is tough to read. Maybe you could lighten that background image a little (I think it's a phone receiver?)

Also, you have 652 validation errors.. wow, that's a lot.
  • Prime
  • Professor
  • Professor
  • User avatar
  • Posts: 935
  • Loc: Liverpool

Post 3+ Months Ago

I've got to admit I'm not impressed on two counts, the website and the offering itself... Have a look at two similar IVR solutions :

http://www.disguisemynumber.co.uk/

http://www.freefaxtoemail.net/

Both totally free services and very similar.

Sorry, but good luck.

Cheers, Prime ... :D
  • Bogey
  • Genius
  • Genius
  • Bogey
  • Posts: 8388
  • Loc: USA

Post 3+ Months Ago

loaded slowly for me...
  • righteous_trespasser
  • Scuffle
  • Genius
  • User avatar
  • Posts: 6230
  • Loc: South-Africa

Post 3+ Months Ago

jameson5555 is right 652 errors ... WOW! What! How the hell did you acomplish that? ... No I'm sorry ... I can't ...
  • Bogey
  • Genius
  • Genius
  • Bogey
  • Posts: 8388
  • Loc: USA

Post 3+ Months Ago

holy bejeeze... Never knew that could be accomplished... nothing against you man... just might be the reason for slow loading on my computer.. gotta fix that. I may help you with some errors. But you need to get started on them :shock:
  • palkey77
  • Born
  • Born
  • palkey77
  • Posts: 4

Post 3+ Months Ago

Yeah, this does load slowly. Like wtf. You should fix a few things here dude.
  • P.T. Yevgeniy
  • Newbie
  • Newbie
  • P.T. Yevgeniy
  • Posts: 8
  • Loc: Rotterdam, NL

Post 3+ Months Ago

Yeah the loadeing of the site wase very very slow... This will nut encourage people to buy your product. Some minor details in lay out for example te text of the prices of the packages....

Good luck
  • shmageki
  • Newbie
  • Newbie
  • shmageki
  • Posts: 7
  • Loc: Portland, ME

Post 3+ Months Ago

Loaded fine for me... I think there's a little too much going on visually... but not bad... looks slightly generic, but professional.

The CSS is a bit sloppy, as people have mentioned... try FF's error console for starts... then W3C validate it.

Good luck.
  • alfonko
  • Newbie
  • Newbie
  • alfonko
  • Posts: 8
  • Loc: uruguay

Post 3+ Months Ago

well.. yes. I didnt program the site, i can assure that if it was up to me i would had used Zend Framework. Anyway... thanks for making me notice that (really amazing)
  • alfonko
  • Newbie
  • Newbie
  • alfonko
  • Posts: 8
  • Loc: uruguay

Post 3+ Months Ago

alfonko wrote:
well.. yes. I didnt program the site, i can assure that if it was up to me i would had used Zend Framework. Anyway... thanks for making me notice that (really amazing)


Although there are lots of errors that came from "option" tag... that's not big deal

Post Information

  • Total Posts in this topic: 11 posts
  • Moderator: Website Reviewers
  • Users browsing this forum: No registered users and 9 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.