SITE REVIEW: www.softech.tk

  • teyjohn
  • Beginner
  • Beginner
  • User avatar
  • Posts: 51
  • Loc: Singapore

Post 3+ Months Ago

Hi guys....

I just created a new website on freelancing services for hardware, software, microchips, programming and websites. This is my first ever website that provide services to the world. So, I hope that you guys can help me review my website. It would be nice if you guys could provide me with some comments, opinion and suggestions.

Visit http://www.softech.tk!

Thank you in advance!!!

^_^
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • Digi Stylers
  • Novice
  • Novice
  • User avatar
  • Posts: 19
  • Loc: UK

Post 3+ Months Ago

I like the actual design, a major thing I noticed though...

Your using bitmaps! They took forever to load and your top "banner" one doesn't fill the whole of the top area which looks untidy because it just sits in the bottom-left corner. Maybe make the navigation links more like links too, it fooled me when i hovered over to see a cursor... i thought it wasn't finished. Apart from that i like the use of colours and layout.

Regards,
Mark
  • teyjohn
  • Beginner
  • Beginner
  • User avatar
  • Posts: 51
  • Loc: Singapore

Post 3+ Months Ago

Yeah.... you're right... I always felt bad when I used Bitmaps... But, the problem is that I can draw a JPEG. Everytime, I draw a picture and saved them as JPEG, the whole picture became ugly.... full of unwanted dots..... Any ideas or recommendations?
  • mhammadd
  • Beginner
  • Beginner
  • mhammadd
  • Posts: 52

Post 3+ Months Ago

Hi, reviewed your site. Its not bad for a first website.
I advice that you create an external style sheet and link to it. I also noticed that pointing on your menu gives a text sign instead of the normal hand symbol. At first i thought that the links doesn't work, maybe us should do something to that too.

Before i recommend anything about your JPG question, it would be nice if you stated the type of software you are using to create your images.. I advice you use fireworks and heres some nice tutorials on creating an interface layout..http://www.templatearchives.com/interfacecreate1.php
  • b_heyer
  • Web Master
  • Web Master
  • User avatar
  • Posts: 4581
  • Loc: Maryland

Post 3+ Months Ago

The webpage took a while to load, and when it finally did the top image "http://www.freewebs.com/softech/Banner1.bmp" does not load. None of the links on the side work, but I am sure you are working on that. Then again it is very possible your page doesn't work at all in mozilla, in which case I'd recommend making it. One way to get around this is if you are using dhtml menu's is to make each link also link to a page that has the same links as what is in your menu, so if someone does have support for the menu they can still get to your pages.

Hope that helps/
  • teyjohn
  • Beginner
  • Beginner
  • User avatar
  • Posts: 51
  • Loc: Singapore

Post 3+ Months Ago

Thanks b_heyer...

But, the links does work... Perhaps, I should try to make sure it works with Mozilla... I'm still new to website design, so... I'm not that good yet.... I'll try to fix this soon... Anyway, thanks for the comments....

^_^
  • b_heyer
  • Web Master
  • Web Master
  • User avatar
  • Posts: 4581
  • Loc: Maryland

Post 3+ Months Ago

you can try just linking the text as well, as I stated. I am assuming you have some sort of menu system?
  • Andrew
  • Novice
  • Novice
  • Andrew
  • Posts: 19

Post 3+ Months Ago

Not all of the links are working. Do you know this?
  • ccb056
  • Graduate
  • Graduate
  • User avatar
  • Posts: 189

Post 3+ Months Ago

Code: [ Select ]

<html>

 <head>
  <title>Softech - Software and Hardware Freelancing</title>
  <meta name="description" content="Softech Incorporated provides affordable freelancing services on software and hardware development, programming work, website creation and graphics design.">
  <meta name="keywords" content="Computer, Freelancing, Hardware, Internet, Microchip, Programming, Software, Web Design">
 </head>

 <frameset rows="*,1" framespacing="0" border="0" frameborder="NO">

  <frame src="http://www.freewebs.com/softech" name="dot_tk_frame_content" scrolling="auto" noresize>
 </frameset>

 <noframes>
  <body>
  </body>
 </noframes>

</html>
  1. <html>
  2.  <head>
  3.   <title>Softech - Software and Hardware Freelancing</title>
  4.   <meta name="description" content="Softech Incorporated provides affordable freelancing services on software and hardware development, programming work, website creation and graphics design.">
  5.   <meta name="keywords" content="Computer, Freelancing, Hardware, Internet, Microchip, Programming, Software, Web Design">
  6.  </head>
  7.  <frameset rows="*,1" framespacing="0" border="0" frameborder="NO">
  8.   <frame src="http://www.freewebs.com/softech" name="dot_tk_frame_content" scrolling="auto" noresize>
  9.  </frameset>
  10.  <noframes>
  11.   <body>
  12.   </body>
  13.  </noframes>
  14. </html>


I wouldnt recomend using frames, the menu doesnt work with mozilla, the image on top is broken

The color scheme is nice.
  • cipher
  • Graduate
  • Graduate
  • User avatar
  • Posts: 157

Post 3+ Months Ago

hey why don't you use the normal hand cursor for links. the text cursor looks really wierd and gives the felling that there are no links actually present. i only knew that they were links for a fact cuz i saw the new link being displayed in the status bar.
  • favouritelink
  • Novice
  • Novice
  • User avatar
  • Posts: 33
  • Loc: seattle

Post 3+ Months Ago

Hi webmaster

You wrote: "But, the links does work... Perhaps, I should try to make sure it works with Mozilla..."

I did it for you I loaded your site in Mozilla and the top banner did not load at all the links don't work so I would recommend to fix this soon.
What I also noted is that while everybody who posted a reply to help you with your website that you did not fix the problems everything is still the same.
  • teyjohn
  • Beginner
  • Beginner
  • User avatar
  • Posts: 51
  • Loc: Singapore

Post 3+ Months Ago

Yeah... I know cuz I'm too busy with my projects. Sorry about that....

^_^

Post Information

  • Total Posts in this topic: 12 posts
  • Moderator: Website Reviewers
  • Users browsing this forum: No registered users and 6 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.