PP

  • jonsimons
  • Newbie
  • Newbie
  • jonsimons
  • Posts: 8

Post 3+ Months Ago

Hi,

this is a cool site i found
  • Anonymous
  • Bot
  • No Avatar
  • Posts: ?
  • Loc: Ozzuland
  • Status: Online

Post 3+ Months Ago

  • Nucleo
  • SausagePorkPie
  • Mastermind
  • User avatar
  • Posts: 2297
  • Loc: UK - England

Post 3+ Months Ago

a link to it would be nice
  • jonsimons
  • Newbie
  • Newbie
  • jonsimons
  • Posts: 8

Post 3+ Months Ago

hehe sorry!!! link
  • Kingsimon999
  • Newbie
  • Newbie
  • Kingsimon999
  • Posts: 5
  • Loc: UK

Post 3+ Months Ago

Nice website!
Very good loading time and good navigation.
I found the reviews of go peds very interesting with the stats and personal review.
I think this website has a lot of potential to do well with a great design and good content its bound to do well. :roll: :roll: :D :D :D
  • pdrodriguez
  • Newbie
  • Newbie
  • User avatar
  • Posts: 13
  • Loc: Ohio

Post 3+ Months Ago

Greetings!

I took a look at your site and had a few comments. First, the concept of the site is great, there are a lot of people looking for this info.

Design Issues: (On my browser) --On the home page, the welcome box to the left--all of the copy does not fit in there. I see a line of copy below the box. There are 5 boxes with a red x in them at the bottom. The links seem to work so it must just be an image problem. Layout looks clean, choice of colors seems appropriate. What is the purpose of your splash page? I would add some sort of tag line or marketing copy to that page to make it clear what your site is about. I had to look twice at the sketch because unless you had goped in your URL I wouldn't have guessed that your site was about gopeds, from the splash page.

Potential problem: I noticed that your home page is greater than 51 mb. This is very large and will take a while to load if you're on a dial up. Also, it seems that some of the navigation links are not working. I.E. I click on medium duty and nothing happens. Also, when you click on a button, i.e. live support (which takes you to another site) it takes forever to get back after pushing the back button. I ended up pushing it twice and ended back at your splash page. Maybe have all of your links open up in a new browser so visitors can just X them out and remain on your site.

Layout and Copy: I like the layout with lots of white space and adequate copy. The site looks very clear and easy to navigate around.
Good Luck

Thanks
pdrodriguez
  • jonsimons
  • Newbie
  • Newbie
  • jonsimons
  • Posts: 8

Post 3+ Months Ago

I can't understand why its working great for me but not for you?

My loading time is quick and the site seems to be working fine?

Could you tell me what browser you are using?

thanks for all your feedback!!
  • pdrodriguez
  • Newbie
  • Newbie
  • User avatar
  • Posts: 13
  • Loc: Ohio

Post 3+ Months Ago

Hello!

Actually, my loading time is great for your site. But I am on cable. If you run your site through the web tools over at sitesolutions in web analysis you will discover the loading times for different connections. It will also tell you the size, etc.

If you are using dsl or cable you can get really spoiled and even forget about load times.

I am using IE 6.0

Thanks,
pdrodriguez
  • butlerboy99
  • Beginner
  • Beginner
  • User avatar
  • Posts: 60
  • Loc: WA

Post 3+ Months Ago

well, it's a very nice looking site. It seems very proffessional. The information is nice, and its organized pretty well. Although, I did notice that you had the link to your downloads section halfway through the page. It should probably be on top, or maybe you should make another bar for site related things like links and downloads and such. The load time was pretty slow for me, even though I'm on cable. It took about 10 seconds to load. I'm using safari with cable modem. And it says on the bottom that the site is best viewed in 1024x768, yet viewing it at 800x600 seems to present no problems at all.
  • DuffMan
  • Beginner
  • Beginner
  • User avatar
  • Posts: 60
  • Loc: Portland, OR

Post 3+ Months Ago

I went to your site to simply review it and now I think I want to buy one of those!

But overall the site looks very professional, I don't have any negative comments!
  • -LynX-
  • Beginner
  • Beginner
  • -LynX-
  • Posts: 62
  • Loc: Liverpool , UK

Post 3+ Months Ago

i like the colours reminds me of a cartoon really nice well done :)
  • cardesign
  • Student
  • Student
  • cardesign
  • Posts: 84

Post 3+ Months Ago

Nice work Jon. The site looks good acronym did a good job on it. I hope you really get somewhere with it. 8)
  • babel
  • Newbie
  • Newbie
  • User avatar
  • Posts: 12

Post 3+ Months Ago

I like the site, the colors.
I dont like the image on the top, they dont mix good.
The logo is cool.
In the Cart page, the image is not that nice looking.

But Overall its very nice and cool at the same time.
I would like to buy one someday. :D

*EDIT* if you put your logo at the middle top and remove these images at the top, it might be better looking.
  • DavyDuke17
  • Graduate
  • Graduate
  • DavyDuke17
  • Posts: 166

Post 3+ Months Ago

SInce its alot better design then I could make, I can't give you much help. In the bottom where all the contact-terms-ect. links are I'm pretty sure theres an error going back to the home page. Some animation or mouse-overs for the menu would be a nice addition. Great action pics and overall nice looking site.
  • conorific
  • Proficient
  • Proficient
  • User avatar
  • Posts: 350
  • Loc: NY

Post 3+ Months Ago

Okay...well... the site itself is fine. No problems there. However:

Quote:
I can't understand why its working great for me but not for you?
My loading time is quick and the site seems to be working fine?


And here we come to the epiphany! Of COURSE it's going to look good in your browser and your OS! But you're not designing for you!

You're designing for Linux, Mac, IE, Nutscrape, Unix, 1024*768, cable, DSL, dial-up, AOL, Mozilla, Opera, Safari, Lynx, 800*600 and a hundred other things![/quote]
  • mrhodes
  • Newbie
  • Newbie
  • mrhodes
  • Posts: 8

Post 3+ Months Ago

Nice site! Only issue i saw was the text not fitting into the boxes on the left, making it hard to read (others have already mentioned this issues). Otherwise, nice site. Nice color scheme.

Mark

Post Information

  • Total Posts in this topic: 15 posts
  • Moderator: Website Reviewers
  • Users browsing this forum: No registered users and 13 guests
  • You cannot post new topics in this forum
  • You cannot reply to topics in this forum
  • You cannot edit your posts in this forum
  • You cannot delete your posts in this forum
  • You cannot post attachments in this forum
 
cron
 

© 1998-2014. Ozzu® is a registered trademark of Unmelted, LLC.