GT

At work, I have a large SAN (Storage Area Network). On a shared drive thats run through a clustered NAS that is directly attached to the SAN, the entire department (~110 people, 200+ workstations including labs) has an excel file that we all use. Unfortunately, some 'person' either on their machine or a lab machine opened the file and now it is locked for editing.

I can't sniff trough 200+ computers so, anyway to force unlock it?

Any way to find the computer responsible. If I can find the IP address and I can lower the number of computers down to a specific lab (by subnets). I have full administrative access to the NAS (Windows 2003 Server Datacenter using DFS and Clustering), the SAN (not much help it will do), and to all the shares. Even logged on as myself and being the only person with full administrative rights on all the files it still wont let me use it. Excel still says its locked for editing.

add a comment
0

15 Answers

  • Votes
  • Oldest
  • Latest
LU

Doesn't Excel usually tell you the username of the person who has it open?

add a comment
0
OP

if the excel file is locked for editing, you'll probably need to find the person by his/her username/author and his/her password to unlock the excel file. you can probably look on its author.

add a comment
0
GT

Doesn't help - It just gave initials. It said 'AAA'.

This one has another 3 letters, but didn't match a person.

I eneded up backing up the file, bringing down the entire DFS link, deleting the file locally on the NAS, Bringing back up the DFS link, and then replacing the file.

Entire department is now getting nasty Email. 😈

add a comment
0
LU

I found this on Ask-Leo.com

On the server, right-click on My Computer, then select Manage, expand Shared Folders, and click on Open Files. There you'll see a list of files on the server that are currently opened by other computers on your network. That'll tell you the User who has the file open. You'll need to then click on Sessions to see what computer(s) that user is connecting from.

From there you could use taskkill to kill the program on the remote computer

TASKKILL /S computername /U domain\username /IM EXCEL.EXE

add a comment
0
GT

NICE! I got to try that tomorrow.

Thanks.

add a comment
0
AL

From there you could use taskkill to kill the program on the remote computer

The bastard operator from hell's favorite tool?

add a comment
0
MB

Actually you don't even need taskkill or even access the offending computer. Just right click the Open File in My Computer as described in lucassix's quote above, and choose "close open file". Works like a charm.

add a comment
0
BE

ATNO / TW s last reply works like a charm.

Thanks ATNO / TW.

add a comment
0
AK

When all else fails, restart Windows explorer on the host machine or just reboot it.

add a comment
0
GS

In case anyone else finds this thread via search and it doesn't quite help their specific case, here's another potential solution...

I had a similar situation: various .xls/.xlsx files on a (Win 2K3/IIS) web server which could not be deleted (but needed to be!). When attempting to delete them either on the box itself or over the network, I would get 'access denied' messages. If I attempted to open the files in Excel (over the network), Excel would report that the file was already in use by some user or other. Trying lucassix's tip of looking in Open Files in the management console, simply showed some files and folders that I had open, but no other users were shown and the locked files weren't listed.

I knew that the users reported by Excel couldn't really have the files open, so it was driving me mad. Rebooting wasn't an option (for this problem).

Eventually I found Microsoft's Handle utility. I'm not allowed to post a link to it here apparently, but just Google it - it's in the SysInternals section of Microsoft's Technet site.

If you run it without parameters and output to a text file, you'll get a nice list of every file handle with the details of the process that has it open.

From this, I found that the (MS) Indexing Service (cidaemon.exe) - used for search in our case - had the files locked. I temporarily stopped the Indexing Service in the Services console, deleted the files without a problem and then restarted the indexing service.

I hope this helps somebody else facing similar frustrations. 🙂

add a comment
0
LE

I don't think any of you addressed the initial question - I'm having the same problem but my data all reside on a NAS using DFS links. On a NAS there is no going on the computer to check and disconnect or kill open files since it is not a Windows machine. My access on the NAS is not at the root level so I can't go in an see open files. The options available on Windows servers are not on this device. I would love any suggestions.

Leisa

add a comment
0
CM

Delete it than reupload this file with shared permission protection...

add a comment
0
RI

If the file is stored over the network, Goto windows folder settings of your desktop of server and enable "show hide protected operating system files". Make sure the original file is not accessed by anyone and delete the file starting with the "~" relevant to the locked out file. This should fix the issue.

add a comment
0
RU

On the server, right-click on My Computer, then select Manage, expand Shared Folders, and click on Open Files. There you'll see a list of files on the server that are currently opened by other computers on your network. That'll tell you the User who has the file open. You'll need to then click on Sessions to see what computer(s) that user is connecting from.

From there you could use taskkill to kill the program on the remote computer

TASKKILL /S computername /U domain\username /IM EXCEL.EXE

This was super useful info. The lab I work at uses a centralized PDF to post a schedule for our pathologists. The file was opened by one of our doctors that is currently off but left their workstation locked.

add a comment
0