Created
Updated
Viewed
30.9k times

Does anyone know how to remove an OS from the OS menu that comes up before Windows? I had two copies of Windows installed and recently removed one, but the copy still shows up on the boot options choices menu when first booting up the computer. How do I remove old boot option entries?

add a comment
1

4 Replies

  • Votes
  • Oldest
  • Latest
Replied
Updated

For Windows XP you can do the following to remove boot option entries:

  1. Open control panel and then system
  2. Select the advanced tab in system window
  3. Click the settings button in Startup and recovery section
  4. In the next window you should see a button labeled Edit (actually there's a label saying "to edit the startup options file manually click edit" on the left of this button)
  5. When you click on this button a file called boot.ini is open, check the section labeled operating systems, there you should see two lines that look similar to this:
    multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows XP Professional" /fastdetect
    
  6. Remove one of the lines
  7. Save the file and reboot
  • 0
    Be a little careful with that. If you delete the wrong one, you might find yourself reinstalling again as you will no longer have the option to boot to the good one. It will probably be the one labeled multi(0)disk(0)rdisk(0)partition(2). Partition 1 should be the good one. You might want to Google around and try to confirm that before you try it. It's been a while since I did that and I'm going on memory. Rather than deleting the line, just type the letters REM and a space in front of it. That way if it gets screwed up, you could possibly boot to safe mode and change it back. — Mark Bowker
  • 0
    This link explains it pretty well. I forgot about the [any text] option. I would use that approach instead. Based on what I just read there you just may have multiple versions of partition1. Although I didn't state there the default (good) one should be the first one listed. — Mark Bowker
  • 0
    I removed the right one, but now I get another option, this one says "windows (default)". What does this mean? and if I click on it again, I get the same error message as before. — risingsun
  • 0
    Hmmmm - not sure. If you only have one in the boot.ini you shouldn't even see the screen. If should go right to the Windows loading stuff. If it helps, this is what my boot.ini looks like: > [boot loader] > timeout=30 > default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS > [operating systems] > multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect This assumes your XP is on the first and only partition. (mine is actually on partition 2 but I changed it for the example.) I'm not suggesting that mine will work for you, but it is a typical one and should do the trick. At least you can compare that to yours and see what the differences are. — Mark Bowker
add a comment
1
Replied
Updated

I removed the right one, but now I get another option, this one says "windows (default)". What does this mean? and if I click on it again, I get the same error message as before.

That happens when the specified Default doesn't match any of the entries under [operating systems].

example:

[boot loader]
timeout=10
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

I changed mine to the above and it did indeed add Windows (Default) to my boot menu.

Here's a useful tip: Get a blank formatted floppy and copy the following files from your boot partition:

  • boot.ini
  • ntldr
  • ntdetect.com

These files can be found on the root of your boot partition. They are hidden so you will have to copy them from a command prompt or enable show hidden and system files. In case your boot.ini file gets trashed, you can use the floppy disk to boot into windows normally and then repair boot.ini.

Edit: I forgot to mention that you will need to format the disk from within Windows 2K/XP. Just right-click on the Floppy drive icon and select format. Don't check ''Create an MS-DOS Startup Disk". Just leave that option unchecked. A fresh floppy out of the box will not work.

  • 0
    thanks a lot guys, it worked. — risingsun
add a comment
1
Replied
Updated

Hey I have basically the same problem as risingsun but the only difference here is that in my boot.ini file it says:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

They are both identical. So, my question is, in the OS Choices menu when the pc boots, are the OS's listed in the same order as they are here?
For example, on my OS choices menu it says:

Microsoft Windows XP Professional
Microsoft Windows XP Professional

The first one is the one I would like to remove. To do this, could I just remove the first line in my boot.ini file?

  • 0
    default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS is the one your computer is booting into if your not picking the other one at boot. That being said the one that is not the default should be the one removed if you don't want to see the choices or just set the time to 1 so it will just flash on flash off quickly. — UniquelyYoursPC
add a comment
0
Replied

For Windows 10 and Windows 11 this has now been greatly simplified. Here are the steps:

  1. Goto Start menu and type System Configuration; or press Win + R and run msconfig

  2. Click on the Boot Tab:
    System configuration boot menu options

  3. You can now easily now Set as default any boot options here.

  4. You can also see what your current default is, and select other boot options to Delete.

add a comment
0