Asked
Updated
Viewed
294.1k times

I have a problem entering regedit in Windows. Every time I try running regedit there is a popup message that says regedit has been disabled by administrator. The exact error message is:

Registry editing has been disabled by your administrator.

How can I enable registry editing? By the way, I'm the administrator so I should have sufficient privileges.

Registry editing has been disabled by your administrator

  • 0
    There is also some virus/spyware/malware that can cause this behavior as well. Wouldn't hurt to post a HiJack This Log just in case. — grinch2171
  • 0
    Is there some sort of virus/spyware/malware that causes this behavior. What should I do? — The^Watcher
  • 0
    Follow Grinch's instructions and post a Hijack This log. — Alkatr0z
add a comment
0

2 Answers

  • Votes
  • Oldest
  • Latest
Answered
Updated
  1. Click Start
  2. Type run and when command appears click on it.
  3. Type gpedit.msc in open field and click OK.
  4. Go to User Configuration in GPEdit.
  5. Go to Administrative Templates.
  6. Go to System.
  7. Right click on Prevent access to registry editing tools.
  8. Click on edit.
  9. Turn off Enabled. Either select Not Configured or Disabled.

Access group policy editor for access to registry editing tools

Disable preventing access to registry editing tools

  • 0
    Unfortunately, that did not work. By the way, I am using Windows XP. — The^Watcher
  • 0
    For me this worked, thanks man, great job, with gpedit.msc, you can do nice things 🙂 — Kinezu
  • 0
    You can also try to use system restore if there is no hope! — alte5
add a comment
1
Answered
Updated

I found that someone else had a similar problem as you. They opened up Task Manager in Windows by hitting Crtl-Esc and looked for ntsysman.exe. They tried to kill the process, but it would immediately restart over and over. Instead they searched their local hard drive for ntsysman.exe and syslog32.exe and deleted it. After rebooting, everything went back to a normal state for them.

  • 0
    WOW, this helped lots thanks stupid spyware! — Neverseen
add a comment
0