Asked
Updated
Viewed
69k times

I went to My Computer on my Windows Machine and my hard drive is not showing there. I have a Maxtor 80GB Firewire external hard drive.

So I then went to Disk Management in Computer Management and partitioned the hard drive and mounted it; however, every time I tried formatting it Windows said that it could not format.

I think I have now unpartitioned it and undone everything and now when I plug in my external hard drive it loads up at the bottom of the taskbar where I can select to safely remove hardware, however, it is still not showing in My Computer and it's not even in Computer Management any longer!

How come my hard drive is not recognized? and what can I do to get it to work properly?

  • 0
    I have a similar issue. My hard disk (Maxtor Home basic) is connected to UBUNTU 9.0, while using data from the hard disk abruptly the hard disk USB is unplugged by a kid. Now when I connect it to the computer again it is not working. But it is showing in device manager -> disk drives. However, I am not able to see it in My Computer. I tried to connect the hard disk in Windows XP, Windows 7, and Unbuntu 9.0. However, it never shows. The hard disk light is glowing, which shows that the hard disk is working. The hard-disk is an externally powered hard drive, Maxtor-home basic, 1 TB. — ant_jar
add a comment
1

3 Answers

  • Votes
  • Oldest
  • Latest
Answered
Updated

I did a little research and found some instructions that might help you. It is possible that you may have a problem with the BIOS on your motherboard, but before going there try this simple little trick.

We want to cut power to the hard drive in question. Unplug the power cord for the external hard drive for approximately 25 minutes. This is important as 10-30 seconds is not usually long enough. If you have a laptop that has the same problem then you must also remove the battery on the laptop to ensure that no power is reaching it.

After the elapsed time, then plug the hard drive back in and re-connect the hard drive to the computer to see if things are now working.

  • 0
    Ok, I will try that. The thing is before it just use to come on my taskbar saying "safely remove hardware" and it wasn't in My Computer. Someone told me to right click my computer and go to management then go to computer management and there I saw it - I actually partitioned it and then set it as a drive but it would not let me format it so I un-done all the partitioning and adding a driver name and since then it doesn't ever appear on computer management either (the disk management section). — djcobra
  • 0
    I tried that, I unplugged and took out everything for 30-40 mins but it still does not seem to work - it says safely remove hardware at the bottom of task manager, and the hard drive is making a noise and the lights are on so I know for a fact the hard drive is not faulty. Also in device manager, it recognizes my hard drive in disc drives but why not in disk management? — djcobra
add a comment
0
Answered
Updated

I have also seen some other instructions that have been posted in a few different forums with success. Maybe this will help.

Do you by chance have some mapped network drives? If so, make sure you have not mapped any to the next drive letter that comes after your local drives. For example:

You have local drives: A:, C:, and D: which are a floppy disk, hard drive, and DVD drive. You then map a network drive to E:. If you next plug in a USB drive, a bug in Windows will cause it to decide that E: is what it should map the USB drive to, causing a collision. All kind of weird results can happen, but one of them is that you cannot see the contents of the drive.

Thus, the fix is to make sure you map your network drive higher up. For instance with network drives start with Z: and work your way backward in the alphabet that way all of your local drives will come first, and all of your network drives will come last.

There used to be a Microsoft support article Q297694 that discussed this.

  • 0
    I've run into that ATNO. So friggin stupid. — grinch2171
add a comment
0
Answered
Updated

I had the same problem with Windows 7. I think it's the same for Windows Vista. Right-click in the Royal Blue bar, and select New Simple Volume. Name the partition, and give it a letter, then give the settings you want. That should solve the problem for you.

add a comment
0