BO
450 9
Asked
Updated
Viewed
10.2k times

I have a PC that I'm trying to fix, and the problem with it is that it can't decide which graphics card to use. It has the graphics card that is built into the motherboard and another graphics card that is plugged in at the bottom.

The problem with it is that it sends the data through the graphics card at random and not through the one that the monitor is connected. I could have the monitor plugged into the external graphics card but the PC will send the image to the internal (built-in) graphics card that I'm not using or vise versa.

If that happens (when I turn on the PC) than I switch the plug from one graphics card to another and then the image appears on the screen. Event viewer log doesn't provide any information that I find to be relevant to the issue. Some issues with .NET framework, error updating (not connected to the internet), the PC shutting down unexpectedly (the owner just did a hard shut down when the PC got confused) and maybe some other things related to the hard shut downs.

Any ideas as to how to troubleshoot the issue or what could be wrong with it? Is there a way to simply set a default graphics card that should be used?

add a comment
1

6 Answers

  • Votes
  • Oldest
  • Latest
Answered
Updated

There are a few things you can try to troubleshoot this issue:

Make sure that the drivers for both graphics cards are up to date. Outdated drivers can cause issues with graphics card switching. You can usually update the drivers through the manufacturer's website or through Windows Update.

Check the BIOS settings to see if there is an option to specify which graphics card should be used as the primary one. You can access the BIOS settings by restarting your computer and pressing the appropriate key (usually F2 or Del) to enter the BIOS setup.

If you are using a dual-monitor setup, try unplugging one of the monitors and see if the issue persists. This can help narrow down whether the issue is with the graphics card or the monitor.

If you are using a desktop PC, make sure that the graphics card is properly seated in the PCI-Express slot and that it is getting enough power. Some graphics cards may require additional power from the power supply unit (PSU) in the form of a PCIe power cable.

If the issue persists, it is possible that there may be a hardware issue with one of the graphics cards or with the motherboard itself. In this case, you may need to replace the faulty hardware in order to fix the issue.

I hope this helps!

add a comment
1
Answered
Updated

I'd think that disabling the onboard video in the BIOS would be your best bet. Don't let MS make the decision for you. Pending your PC, entering the BIOS could be any of the Function keys or ESC or DEL. My laptop wil only go into the BIOS if you hold down the F2 key when you power on the machine.

Good Luck.

add a comment
1
Answered
Updated

Disable your integrated graphics card unit (iGPU).

Here are the steps to do this with Windows 10:

  1. Go to Start Menu and type / goto "Device Manager"
  2. Expand "Display Adapters"
  3. Right-click on the entry for your iGPU
  4. Select "Disable device"

Now attempt to reboot and Windows should always use your actual graphics card.

Disable integrated graphics card in device manager

Note: In the screenshot above I do not have an iGPU shown, you would disable that, not the graphics card you want to use.

add a comment
0
Answered
Updated

It sounds like the issue you're encountering is related to how the PC is handling the multiple graphics cards. It's possible that the PC is not properly configured to use one graphics card as the primary, and instead is randomly switching between the two cards.

  • Update the graphics card drivers: Make sure that the drivers for both graphics cards are up to date. You can download the latest drivers from the manufacturer's website.

  • Configure the BIOS settings: Some PCs allow you to configure the BIOS settings to specify which graphics card should be used as the primary. Check the manual for your PC's motherboard to see if there is an option to set the primary graphics card.

  • Use the Device Manager: Windows has a built-in Device Manager that allows you to view and manage the hardware on your PC. You can use it to disable the built-in graphics card and ensure that the external graphics card is being us. Check for any conflicts: It's possible that there may be a conflict between the two graphics cards that is causing the issue. Check the Event Viewer log for any error messages related to the graphics cards.

  • Check for a software problem: Sometimes, the issue can be caused by a software problem. Check if any recent updates have been installed or if any new software has been installed. Also, check for any software conflicts.

  • Check for a hardware problem: If none of the above steps resolve the issue, it may be a hardware problem. Check the connections of the graphics cards and make sure that they are properly seated. Also, check for any damages on the graphics cards.

  • Set the default graphics card: You can set the default graphics card by going to the Graphics properties of the control panel and then select the graphics card that you want to use as the default.

add a comment
0
Answered
Updated

You can also choose a default graphics card in Windows per application. Here's how:

  1. Right-click on your desktop and select "Display settings."
  2. Scroll down and click on "Graphics settings."
  3. Under "Choose an app to set preference," click on "Classic app."
  4. Click on "Browse" and select the application for which you want to set a default graphics card.
  5. Once you have selected the application, click on "Options."
  6. Under "Select the graphics preference," choose "High performance" if you want to use your dedicated graphics card as the default. Choose "Power saving" if you want to use your integrated graphics card as the default.
  7. Click on "Save" to apply the changes.

Note that the above steps may vary slightly depending on the version of Windows you are using. Additionally, not all computers have both a dedicated graphics card and an integrated graphics card, so the option to choose a default graphics card may not be available on your system.

add a comment
0
Answered
Updated

If you're wondering whether you can choose a default graphics card in Windows, the answer is yes! The process may vary a bit depending on your setup, but I'll try to give you some general instructions that should work for most cases.

First, you'll need to open the Windows "Settings" app. You can do this by clicking on the gear icon in the Start menu or by pressing the Windows key + I on your keyboard. Once you're in the Settings app, click on "System" and then "Display" in the left-hand menu.

Scroll down a bit until you see a link that says "Graphics settings" and click on it. Here's where you can set the default graphics card for specific apps or games. To get started, click the "Browse" button under "Choose an app to set preference" and select the executable file (.exe) for the app or game you want to configure.

Once you've added the app, you should see it in the list with some options below it. Click on the app in the list and then click the "Options" button. This will open up a menu where you can specify the default graphics card to use.

Look for the "Graphics specifications" section and you should see a drop-down menu labeled "Choose a graphics preference". Depending on your system, you may have the option to choose between your integrated graphics card (usually built into your CPU) and a dedicated graphics card (if you have one installed). Select the graphics card you want to use by default, then click "Save" to apply the changes.

Note that some graphics cards may have their own software or drivers that allow you to customize settings even further. If you're not sure where to find these settings or how to configure them, I'd recommend checking the website for your graphics card manufacturer for more information.

I hope this helps! Let me know if you have any other questions or if there's anything I can clarify for you.

add a comment
-1