5.4k times

My PC runs on Windows XP sp1a, now much slower on the network. It takes me a pretty long time to transfer a 10MB file. 😟

My LAN has one domain controller running on ms windows 2k advanced server. Each workstation runs on windows XP sp1a and every client has 100Mbps of NIC connection speed.

Transfer the files (general files) from other clients to clients, from clients to server, and vice versa, it is much faster compared to transferring files from/to my PC (around 4 times slower).

Most of the other clients are smaller than mine in hardware capacity. Actually, mine is a pretty good computer ( PIV 2.5Ghz, 512 MB, 60GB).

I have tried to change the NIC with other clients and also change the network wall access point, but it is still slow on the network and the collusion on the hub is so small. So I think it may not due to the NIC, access point, or collusion.

I also looked into the process in Task Manager, but there are no strange processes while transferring files. My Norton Antivirus is always up to date, so I don't think it is due to the virus.

  • 0
    Your question is pretty vague, you will have to give us more details. What kind of network is it? What are you transfering? to a server withing the local network? or something outside the network? — Vladdrac
add a comment

1 Answer

  • Votes
  • Oldest
  • Latest

My first guess is that your network properties for your computer are set to 10Mbps half duplex instead of 100Mbps full duplex. (Even if your card is a 100Mbps card, you still have to have the settings right.) Almost every time I've seen network connectivity slow like you've described it invariably comes back to that setting. You could set it to Auto, but I always prefer to specify the 100Mbps Full Duplex.

At the moment I'm on Win2K and it's inconvenient to switch to XP, but if you go to your network card configuration in network properties, you should find it under the Advanced tab, or somewhere similar like this.

  • 0
    I had a similar problem. I had a built-in intel network thing on my mobo, but the transfer rate was rubbish. I installed a separate NIC and it worked fine. So would this work for me too? I just checked the same option and it shows that mine was running at 100MPS/Half Duplex, could that have been the problem? I could always use my separate NIC elsewhere — Nucleo
  • 0
    Half Duplex is one-way communication. In other words, it can only transmit or receive at any given moment. Full duplex allows simultaneous transmission and receipt. Auto detect usually will take care of it, but not always. That's why I always change it as noted above. The speed difference is significant, even with local LAN transfers. — Mark Bowker
  • 0
    Yeah, that sounds right. But there is a good chance that something is configured wrong if it is just his computer. Btw, do people even use half duplex anymore? — Vladdrac
  • 0
    Yes, my NIC setting is set to auto for Link speed/ Duplex Mode. I try some of these settings: First I changed to 100Mb Full Mode/10MB Full Mode or half: the speed is too slow. E.g. my Ms Firewall client can not found my ISA server, I can not open my Ms Outlook XP( always retry to find the Ms Exchange server) and can not list files/folder on the map drive. The Link speed shown is 10Mbps.I then changed to 100Mb Half Mode: the speed is pretty fast. e.g transferring files faster, but when I right-click on any file in my Map drive it is pretty slow like before (set to auto mode). The speed of the connection is show 100Mbps when i change to 100MB half Mode. — ineedu4eva
  • 0
    Interesting that I just had this problem with my Unifi Dream Machine Pro (UDM Pro). Normally I was getting about 300 Mbps down and 10 Mbps up and I had noticed that its daily speed test was now showing about 90 Mbps down and 10 Mbps up for the last week. Took me a bit but finally realized that it the WAN connection was set to auto and instead of selecting 1 Gbps for the port speed it was selecting 100 Mbps. I changed this from auto to 1 Gbps and now I am back to the 300/10 speed. — Brian Wozeniak
add a comment